couchdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Robert Newson <>
Subject Re: [jira] Commented: (COUCHDB-837) Adding stale=partial
Date Tue, 27 Jul 2010 14:30:14 GMT
err, true/false on that last one obv.

On Tue, Jul 27, 2010 at 3:29 PM, Robert Newson <> wrote:
> agree with davisp that 'stale=relaxed' isn't intuitive at all. "How
> can stale be relaxed?".
> No better idea here either, though. stale=ok has painted us into a
> corner. There's not many alternatives to 'ok' that parse well. A
> separate parameter might be preferable: update=true/false would
> activate the update (or not) and stale=ok would be the flag for
> whether the call blocks for the update or not. perhaps better, but
> can't be done for 1.x, update=true/false&block_for_update=false/false
> would allow the three sane permutations.
> B.
> On Tue, Jul 27, 2010 at 3:20 PM, Paul Joseph Davis (JIRA)
> <> wrote:
>>    [
>> Paul Joseph Davis commented on COUCHDB-837:
>> -------------------------------------------
>> @Jason - Good point on idempotent GET's
>> @Filipe - I don't really like it. There's nothing about "stale=relaxed" that in any
way indicates what its for. A good test might be to ask #couchdb "what does stale=ok do, and
if stale=relaxed existed, what would you guess it does". Unless someone's been paying attention
to this ticket I'd doubt that they're going to come up with "its stale=ok but starts a re-indexing
pass". Then again, I agree with @jchris, I don't have any better ideas so its up to you.
>>> Adding stale=partial
>>> --------------------
>>>                 Key: COUCHDB-837
>>>                 URL:
>>>             Project: CouchDB
>>>          Issue Type: Improvement
>>>         Environment: all released and unreleased versions
>>>            Reporter: Filipe Manana
>>>            Assignee: Filipe Manana
>>>         Attachments: stale_partial.patch
>>> Inspired by Matthias' latest post, at,
section "Views are updated on read access", I added a new value to the "stale" option named
"partial" (possibly we need to find a better name).
>>> It behaves exactly like "stale=ok" but after replying to the client, it triggers
a view update in the background.
>>> Patch attached.
>>> If no one disagrees this isn't a good feature, or suggest a better parameter
value name, I'll commit.
>> --
>> This message is automatically generated by JIRA.
>> -
>> You can reply to this email to add a comment to the issue online.

View raw message