couchdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Zachary Zolton <zachary.zol...@gmail.com>
Subject Re: [jira] Commented: (COUCHDB-837) Adding stale=partial
Date Tue, 27 Jul 2010 02:02:04 GMT
On Monday, July 26, 2010, Paul Joseph Davis (JIRA) <jira@apache.org> wrote:
>
>     [ https://issues.apache.org/jira/browse/COUCHDB-837?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12892572#action_12892572
]
>
> Paul Joseph Davis commented on COUCHDB-837:
> -------------------------------------------
>
> @filipe - Awesome
> @janl - I'd agree with Simon that stale=once is too clever and could be misleading.
> @Chris - okgo makes me laugh
> @Simon - So far I think this is the best proposal. There are two intentions, and unless
a sufficiently acceptable value for stale can be found that indicates both, then I'd say two
parameters is probably best
> @Chrisagain - While I agree that stale=ok was never intended to serve as a way to delay
index updates, I wouldn't be surprised if quite a few people are using it to schedule index
updates for off-peak traffic times. We could argue that the default should be to reindex with
a new stale=noreindex option or some such though.
> @jira - I wish you didn't suck so much.
>
>> Adding stale=partial
>> --------------------
>>
>>                 Key: COUCHDB-837
>>                 URL: https://issues.apache.org/jira/browse/COUCHDB-837
>>             Project: CouchDB
>>          Issue Type: Improvement
>>         Environment: all released and unreleased versions
>>            Reporter: Filipe Manana
>>            Assignee: Filipe Manana
>>         Attachments: stale_partial.patch
>>
>>
>> Inspired by Matthias' latest post, at http://www.paperplanes.de/2010/7/26/10_annoying_things_about_couchdb.html,
section "Views are updated on read access", I added a new value to the "stale" option named
"partial" (possibly we need to find a better name).
>> It behaves exactly like "stale=ok" but after replying to the client, it triggers
a view update in the background.
>> Patch attached.
>> If no one disagrees this isn't a good feature, or suggest a better parameter value
name, I'll commit.
>
> --
> This message is automatically generated by JIRA.
> -
> You can reply to this email to add a comment to the issue online.
>
>

I like having the two params best, but calling it reindex might trick
folks into thinking it'll rebuild the whole thing.

How does stale=ok&update_index=true sound?

Mime
View raw message