couchdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jan Lehnardt (JIRA)" <>
Subject [jira] Commented: (COUCHDB-837) Adding stale=partial
Date Tue, 27 Jul 2010 06:55:19 GMT


Jan Lehnardt commented on COUCHDB-837:

@Simon, +1 on Lyam Lynch.
@Paul, great conversation digest form. I also agree that low latency and no-index-updates
are two distinct features that people rely on.
@Chris, I don't consider the current stale=ok behaviour a bug. We also shouldn't go and change
API semantics in a what I think of as a significant 
               way (unless we plan to ship it for CouchDB 2.0*).
               reduce=false doesn't make any sense at all on a non-reduce query (we actually
barf at it, which I consider a bug), yet it is there.

(* I have waited three long years to finally become the CouchDB API conservative :D)

We have three options:
  add a stale=... value (my preference if we can make it work)
  add a update_index=true (option that is a no-op on non-stale=ok views)
  treat stale=ok as a legacy API and introduce a new one, say (for the sake of an example
that is "different") options=["stale", "update-index"]

I think it is worth bikeshedding over this for a while, there's no hurry to implement this


I wouldn't mind stale=freshen, but I'm not excited about it.
I do not like stale=lazy because to me it more describes default view behaviour.

> Adding stale=partial
> --------------------
>                 Key: COUCHDB-837
>                 URL:
>             Project: CouchDB
>          Issue Type: Improvement
>         Environment: all released and unreleased versions
>            Reporter: Filipe Manana
>            Assignee: Filipe Manana
>         Attachments: stale_partial.patch
> Inspired by Matthias' latest post, at,
section "Views are updated on read access", I added a new value to the "stale" option named
"partial" (possibly we need to find a better name).
> It behaves exactly like "stale=ok" but after replying to the client, it triggers a view
update in the background.
> Patch attached.
> If no one disagrees this isn't a good feature, or suggest a better parameter value name,
I'll commit.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message