couchdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Volker Mische (JIRA)" <j...@apache.org>
Subject [jira] Commented: (COUCHDB-837) Adding stale=partial
Date Tue, 27 Jul 2010 14:32:17 GMT

    [ https://issues.apache.org/jira/browse/COUCHDB-837?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12892797#action_12892797
] 

Volker Mische commented on COUCHDB-837:
---------------------------------------

I agree that stale=relaxed doesn't really make clear what it is about.
Perhaps:
stale=trigger
stale=trigger-up
stale=trigger-update
stale=start-update
stale=start-up


> Adding stale=partial
> --------------------
>
>                 Key: COUCHDB-837
>                 URL: https://issues.apache.org/jira/browse/COUCHDB-837
>             Project: CouchDB
>          Issue Type: Improvement
>         Environment: all released and unreleased versions
>            Reporter: Filipe Manana
>            Assignee: Filipe Manana
>         Attachments: stale_partial.patch
>
>
> Inspired by Matthias' latest post, at http://www.paperplanes.de/2010/7/26/10_annoying_things_about_couchdb.html,
section "Views are updated on read access", I added a new value to the "stale" option named
"partial" (possibly we need to find a better name).
> It behaves exactly like "stale=ok" but after replying to the client, it triggers a view
update in the background.
> Patch attached.
> If no one disagrees this isn't a good feature, or suggest a better parameter value name,
I'll commit.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message