couchdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sebastian Cohnen (JIRA)" <>
Subject [jira] Commented: (COUCHDB-837) Adding stale=partial
Date Tue, 27 Jul 2010 15:17:17 GMT


Sebastian Cohnen commented on COUCHDB-837:

My first thought was something like: stale=ok&suppress_update=true (I like readable parameter

But what about keeping stale=ok in its current form for backward compatibility and introduce
a new parameter? stale=ok is somewhat understandable (and known), but combining it with this
new behavior feels kind of odd to me. This would "free" the mindset and you don't need to
construct a new parameter in addition to stale=ok or a new value for the stale param. And
no, I don't have a good idea for a name for this case :)

> Adding stale=partial
> --------------------
>                 Key: COUCHDB-837
>                 URL:
>             Project: CouchDB
>          Issue Type: Improvement
>         Environment: all released and unreleased versions
>            Reporter: Filipe Manana
>            Assignee: Filipe Manana
>         Attachments: stale_partial.patch
> Inspired by Matthias' latest post, at,
section "Views are updated on read access", I added a new value to the "stale" option named
"partial" (possibly we need to find a better name).
> It behaves exactly like "stale=ok" but after replying to the client, it triggers a view
update in the background.
> Patch attached.
> If no one disagrees this isn't a good feature, or suggest a better parameter value name,
I'll commit.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message