couchdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stephen Prater (JIRA)" <>
Subject [jira] Created: (COUCHDB-811) ["error","unknown command"] should be ["fatal","unknown command"]
Date Fri, 25 Jun 2010 19:42:51 GMT
["error","unknown command"] should be ["fatal","unknown command"]

                 Key: COUCHDB-811
             Project: CouchDB
          Issue Type: Bug
          Components: JavaScript View Server
    Affects Versions: 0.11
            Reporter: Stephen Prater
            Priority: Minor

As far as I can tell from a review of the code, this is the only place where an "error" return
value is also supposed to kill the view server.  Since "fatal" errors always kill it, it seems
like this should be ["fatal","unknown command"] just for consistency.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message