couchdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Zachary Zolton <zachary.zol...@gmail.com>
Subject Re: [VOTE] Apache CouchDB 0.11.0 release, second round
Date Thu, 25 Mar 2010 01:28:36 GMT
Oh, BTW, I meant to +1 back then... Passes the tests for my app (^_-)

On Wed, Mar 24, 2010 at 5:33 PM, Benoit Chesneau <bchesneau@gmail.com> wrote:
> On Wed, Mar 24, 2010 at 5:29 PM, Jan Lehnardt <jan@apache.org> wrote:
>>
>> On 24 Mar 2010, at 09:25, Benoit Chesneau wrote:
>>
>>> On Wed, Mar 24, 2010 at 5:18 PM, Jan Lehnardt <jan@apache.org> wrote:
>>>>
>>>> On 24 Mar 2010, at 02:44, Noah Slater wrote:
>>>>
>>>>>
>>>>> On 24 Mar 2010, at 09:40, Brian Candler wrote:
>>>>>
>>>>>> Anyway, nobody else seems to have had this problem, it's quite possibly
>>>>>> something to do with my setup, and browser-based tests are fragile
anyway.
>>>>>> Hence I'm not going to vote against the release.  It's a 0 from
me.
>>>>>
>>>>> Not true, you are the second to report it in this vote.
>>>>>
>>>>> Any of the developers (Jan?) want to comment on how serious this bug
is?
>>>>
>>>> Brian, Benoit, can you both double check and do a clean-slate installation
into a new --prefix if you haven't done so?
>>>>
>>>>> ** {{badmatch,{error,eacces}},
>>>>
>>>>
>>>> From Brian's stacktrace, I'm seeing the eaccess error which suggests that
CouchDB doesn't have write permissions to local.ini (or local_dev.ini, if you run in make
dev mode).
>>>>
>>>> --
>>>>
>>>>> [Wed, 24 Mar 2010 09:00:50 GMT] [info] [<0.113.0>] OS Process #Port<0.1864>
Log :: function raised exception (new ReferenceError("map_funs is not defined", "")) with
doc._id 8450bfd7a0371f80a9baf032553367f4
>>>>> …
>>>>> [Wed, 24 Mar 2010 09:00:50 GMT] [info] [<0.113.0>] OS Process #Port<0.1864>
Log :: function raised exception (new ReferenceError("map_results is not defined", "")) with
doc._id 8450bfd7a0371f80a9baf032553367f4
>>>>
>>>> These come from the view server and look like there's a weird condition.
Chris, maybe you can comment on this?
>>>>
>>>> Cheers
>>>> Jan
>>>> --
>>> like i said i redid install. alsso have the same error in  dev mode.
>>> Read my previous mail about it (more details in it if I remember). It
>>> was really hard to have all tests ok yesterday. I will retry it later
>>> tonight when i'm back at my office.
>>
>> I only see
>>
>>> but on osx i had really bad times with js tests on ff 3.6/snow leopard
>>> on my macbook. Sometimes changes  tests where failing (due to io I
>>> guess) and if you stop  the tests  they let the config in bad state
>>> and it's not resetted in tests apparently, all tests were failing due
>>> to auth.
>>
>> More info would be great :) Thanks Benoit.
>>
>> Cheers
>> Jan
>> --
>
> so i don't get the stuff I had yesterday with previous artefact.
> However changes tests only work when I launch it alone. I supposed
> it's due to slowness of macbook IO. Others tests are ok. make check is
> ok
>
> So traditional review:
> Darwin enlil.local 10.2.0 Darwin Kernel Version 10.2.0: Tue Nov  3
> 10:37:10 PST 2009; root:xnu-1486.2.11~1/RELEASE_I386 i386
> make check ok
> js tests : ok (modulo the changes tests which fails on random point)-
>
> OpenBSD pollen.nymphormation.org 4.7 GENERIC.MP#2 amd64
> make check: ok
> js tests ok
>
> so +1 for me.
>
> I will add later the linux tests.
>
> - benoit
>

Mime
View raw message