couchdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Paul Joseph Davis <paul.joseph.da...@gmail.com>
Subject Re: make check fails
Date Tue, 17 Nov 2009 08:16:06 GMT




On Nov 17, 2009, at 2:24 AM, Vlad GURDIGA <gurdiga@gmail.com> wrote:

> On Mon, Nov 16, 2009 at 8:42 PM, Paul Davis <paul.joseph.davis@gmail.com 
> > wrote:
>> On Mon, Nov 16, 2009 at 6:05 AM, Vlad GURDIGA <gurdiga@gmail.com>  
>> wrote:
>>> On Fri, Nov 13, 2009 at 5:54 PM, Paul Davis <paul.joseph.davis@gmail.com 
>>> > wrote:
>>>> On Fri, Nov 13, 2009 at 10:47 AM, Paul Davis
>>>> <paul.joseph.davis@gmail.com> wrote:
>>>>> On Fri, Nov 13, 2009 at 8:15 AM, Vlad GURDIGA  
>>>>> <gurdiga@gmail.com> wrote:
>>>>>> Hello,
>>>>>>
>>>>>> I'm not sure it's the right list to send this, so, excuse me if 

>>>>>> I'm
>>>>>> wrong, and please advise.
>>>>>>
>>>>>> Here is the report of my "make check": http://pastie.org/697173
>>>>>>
>>>>>> If more logs are needed, let me know.
>>>>>>
>>>>>
>>>>> Can you paste the output of running this from the  CouchDB src  
>>>>> directory?
>>>>>
>>>>> $ prove -v test/etap/*.t
>>>>>
>>>>> Paul Davis
>>>>>
>>>>
>>>> Also, does ./utils/run work for you?
>>>
>>> Looks good:
>>>
>>> [vladd@kpax couchdb]$ pwd
>>> /home/vladd/src/couchdb
>>> [vladd@kpax couchdb]$ ./utils/run
>>> Apache CouchDB 0.11.0b835834 (LogLevel=info) is starting.
>>> Apache CouchDB has started. Time to relax.
>>> [info] [<0.29.0>] Apache CouchDB has started on http://127.0.0.1:5984/
>>> ^C
>>> [vladd@kpax couchdb]$
>>>
>>>
>>> After starting it with ./utils/run I've tried to run the "Test  
>>> Suite"
>>> from Futon and the only failing tests are oauth, replication, and
>>> security_validation.
>>>
>>>
>>>
>>>>
>>>> Paul Davis
>>>>
>>>
>>
>> Vlad,
>>
>> $ ERL_FLAGS="-pa ./test/etap" prove -v test/etap/*.t
>
> This still seems to fail some tests: http://pastie.org/702238.
>
> I even "svn update"-d a minute ago and retried ./bootstrap &&
> ./configure && make && make check, but it still has some failures:
> http://pastie.org/702240.
>
> On my home 32-bit FC11, everything seems to be okay, I've checked last
> night. :-/ I'm kinda tensed that it may be that is something I'm doing
> wrong, or I'm missing something, or it's something wrong with my
> 64-bit FC11?! What else should I check to make sure it's not the case
> and I'm not wasting your time?
>
> Thank you!
>
>
>>
>> or
>>
>> $ ./test/etap/run
>>
>> In the updates to the build system I added a helper in the test
>> directory to specify paths to files. If run doesn't exist, you
>> probably need to do:
>>
>> $ ./bootstrap && ./configure && make
>>
>> To get the new build system updates.
>>
>> HTH,
>> Paul Davis
>>

Much closer. Can you run those individually to get the verbose output.  
If you still have a patched run.tpl you should make it "prove -v" in  
your diff.

Then it should just be:

$ ./test/etap/run test/etap/11*.t

You don't happen to have weird firewall rules that could prevent  
replication to 127.0.0.1 or anything right?  That's about the only  
reason I can think of that would allow 070 to pass but not the 11x  
replication tests.

Paul Davis

Mime
View raw message