couchdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mikeal Rogers <mikeal.rog...@gmail.com>
Subject Re: Increasing Spidermonkey version
Date Wed, 18 Nov 2009 21:01:04 GMT
>
> Also, I'm hesitant to upgrade our minimum version requirement. The SM
> release story is less than awesome. The only tarballs at [3] are for
> 1.7 and 1.8.0 which is a weird limbo version between 1.7 and 1.8.1.
> Not to mention its got a whacky build system that requires a specific
> version of Autoconf. So, yeah, making the upgrades progressive would
> be awesome.
>

I'm a little worried about what effect minimum required versions vs. usable
version will have on application portability.

Newer versions of Spidermonkey, and other js interpreters if we plan on
supporting them, support different versions of the javascript language which
could lead to applications not being portable between different CouchDBs of
the same CouchDB version but with differing js interpreters.

-Mikeal

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message