couchdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brian Candler <B.Cand...@pobox.com>
Subject Re: libmozjs-dev conflicts with firefox on Ubuntu
Date Wed, 25 Nov 2009 12:09:30 GMT
On Wed, Nov 25, 2009 at 09:35:57AM +0000, Brian Candler wrote:
> Maybe the ubuntu-server flavour would be OK too, I haven't tried that for
> 9.10.

I upgraded a VM from ubuntu-server jaunty to ubuntu-server karmic, on the
grounds that I would have to do it sooner or later anyway.

The good news:

* ubuntu-server still doesn't install the ubuntu couchdb package by default

* libmozjs-dev remained installed happily (no firefox/xulrunner for it to
  conflict with)

* I was able to build r884057 against libmozjs-dev and it works.
  (I was confused by a whole load of invalid_json errors being thrown;
  it turned out to be that under /usr/local/lib/couchdb/erlang/lib
  I had both mochiweb-r97 and mochiweb-r113, and zapping r97 fixed
  everything. I believe erlang thinks that r97 > r113 :-)

The bad news:

* if you wanted to use xulrunner-dev, you would get a metric crapload of
  irrelevant packages installed as well.

# apt-get install xulrunner-dev
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  binutils-static
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  dictionaries-common fontconfig hicolor-icon-theme hunspell-en-us libasound2
  libatk1.0-0 libatk1.0-data libavahi-client3 libavahi-common-data
  libavahi-common3 libcairo2 libcanberra0 libcups2 libdatrie1
  libdirectfb-1.2-0 libgtk2.0-0 libgtk2.0-bin libgtk2.0-common
  libhunspell-1.2-0 libidl0 libjasper1 libjpeg62 libnss3-1d libnss3-dev
  libogg0 libpango1.0-0 libpango1.0-common libpixman-1-0 libpng12-0
  libstartup-notification0 libsysfs2 libtdb1 libthai-data libthai0 libtiff4
  libts-0.0-0 libvorbis0a libvorbisfile3 libxcb-atom1 libxcb-aux0
  libxcb-event1 libxcb-render-util0 libxcb-render0 libxcomposite1 libxcursor1
  libxfont1 libxrandr2 tsconf x-ttcidfont-conf xfonts-encodings xfonts-utils
  xulrunner-1.9.1 xulrunner-1.9.1-dev
Suggested packages:
  ispell jed-extra hunspell openoffice.org-hunspell openoffice.org-core
  libasound2-plugins libcanberra-gtk0 libcanberra-pulse cups-common
  librsvg2-common gvfs libjasper-runtime ttf-japanese-gothic
  ttf-japanese-mincho ttf-thryomanes ttf-baekmuk ttf-arphic-gbsn00lp
  ttf-arphic-bsmi00lp ttf-arphic-gkai00mp ttf-arphic-bkai00mp
The following packages will be REMOVED
  libmozjs-dev
The following NEW packages will be installed
  dictionaries-common fontconfig hicolor-icon-theme hunspell-en-us libasound2
  libatk1.0-0 libatk1.0-data libavahi-client3 libavahi-common-data
  libavahi-common3 libcairo2 libcanberra0 libcups2 libdatrie1
  libdirectfb-1.2-0 libgtk2.0-0 libgtk2.0-bin libgtk2.0-common
  libhunspell-1.2-0 libidl0 libjasper1 libjpeg62 libnss3-1d libnss3-dev
  libogg0 libpango1.0-0 libpango1.0-common libpixman-1-0 libpng12-0
  libstartup-notification0 libsysfs2 libtdb1 libthai-data libthai0 libtiff4
  libts-0.0-0 libvorbis0a libvorbisfile3 libxcb-atom1 libxcb-aux0
  libxcb-event1 libxcb-render-util0 libxcb-render0 libxcomposite1 libxcursor1
  libxfont1 libxrandr2 tsconf x-ttcidfont-conf xfonts-encodings xfonts-utils
  xulrunner-1.9.1 xulrunner-1.9.1-dev xulrunner-dev
0 upgraded, 54 newly installed, 1 to remove and 0 not upgraded.
Need to get 22.9MB of archives.
After this operation, 105MB of additional disk space will be used.
Do you want to continue [Y/n]? n
Abort.

So I have decided against this for now.

Cheers,

Brian.

Mime
View raw message