couchdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Paul Joseph Davis (JIRA)" <j...@apache.org>
Subject [jira] Commented: (COUCHDB-490) couchdb execution fail on osx snow leopard
Date Sun, 06 Sep 2009 05:33:57 GMT

    [ https://issues.apache.org/jira/browse/COUCHDB-490?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12751828#action_12751828
] 

Paul Joseph Davis commented on COUCHDB-490:
-------------------------------------------

Been tearing my hair out over this one. Tried writing bits for Homebrew right off and ended
up where people are at with the segfault. it comes from loading couch_erl_driver. Using GDB
to check the traceback points at some OS X internals that are ungoogleable. Replaced with
MacPorts and same thing. Moved MacPorts out of the path and tried with local installs of spidermonkey
and icu and had sucess. Moved macports back into the path and got an error. "port uninstall
spidermonkey" and tried again and met with success. (Custom spidermonkey in /usr/local/...)

So it looks like it's the spidermonkey (or nspr) build causing issues. I'm still investigatoring.

> couchdb execution fail on osx snow leopard
> ------------------------------------------
>
>                 Key: COUCHDB-490
>                 URL: https://issues.apache.org/jira/browse/COUCHDB-490
>             Project: CouchDB
>          Issue Type: Bug
>    Affects Versions: 0.10
>         Environment: macosx snow leopard : Darwin enlil.local 10.0.0 Darwin Kernel Version
10.0.0: Fri Jul 31 22:47:34 PDT 2009; root:xnu-1456.1.25~1/RELEASE_I386 i386
>            Reporter: Benoit Chesneau
>             Fix For: 0.10
>
>
> With a fresh install of macosx snow leopard on a formarted hard disk I can't get latest
trunk of couchdb running. I get this error :
> Trace/BPT trap
> Full trace of error is here :
> http://friendpaste.com/3qXyIIHhrd8N3fObiDgPcx
> icu, nspr, spidermonkey and erlang have been built for 64bits.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message