couchdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Paul Davis <paul.joseph.da...@gmail.com>
Subject Re: svn commit: r804428 - in /couchdb/trunk/src/couchdb: couch_config.erl couch_config_writer.erl couch_httpd_db.erl couch_log.erl couch_server.erl couch_view.erl
Date Sun, 16 Aug 2009 02:23:17 GMT
Totally wasn't paying attention to the commit message. Looks like the
actual error is that didn't update configure.ac to check for the
version we now require.

I'm gonna check that call in in a few seconds. CouchDB now requires
R12B5 or later.

Paul

On Sat, Aug 15, 2009 at 10:05 PM, Paul Davis<paul.joseph.davis@gmail.com> wrote:
> Curt,
>
> Yeah, we accidentally let a couple calls into CouchDB that are only
> valid in R12B5 or later versions of Erlang. There's another thread [1]
> to consider whether it's time to upgrade our Erlang dependency.
>
> [1] http://mail-archives.apache.org/mod_mbox/couchdb-dev/200908.mbox/%3Ce2111bbb0908141843ib492592vae10accb815ed36f@mail.gmail.com%3E
>
> HTH,
> Paul Davis
>
> On Sat, Aug 15, 2009 at 9:40 PM, Curt Arnold<carnold@apache.org> wrote:
>> Doing a build and install on Ubuntu 8.10 x86  on Amazon EC2 (ami-5059be39)
>> with the current HEAD (804543) resulted in the following error.  I was able
>> to install without issue using rev 798283 using the same script.  The rev
>> just before the re commit, also failed but with a different message.
>>
>>
>> {"init terminating in do_boot",{{badmatch,{error,{undef,[{re,split,[<<3890
>> bytes>>,[13,10,124,10,124,13,124,26],[{return,list}]]},{couch_config,parse_ini_file,1},{couch_config,'-init/1-fun-0-',1},{lists,map,2},{couch_config,init,1},{gen_server,init_it,6},{proc_lib,init_p,5}]}}},[{couch_server_sup,start_server,1},{erl_eval,do_apply,5},{erl_eval,exprs,5},{init,start_it,1},{init,start_em,1}]}}
>> init terminating in do_boot ()
>>
>>
>> erl -v reports 5.6.3.
>>
>

Mime
View raw message