couchdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Antony Blakey (JIRA)" <j...@apache.org>
Subject [jira] Commented: (COUCHDB-365) Replication hangs and won't restart
Date Thu, 28 May 2009 22:17:45 GMT

    [ https://issues.apache.org/jira/browse/COUCHDB-365?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12714195#action_12714195
] 

Antony Blakey commented on COUCHDB-365:
---------------------------------------

After this happens, I get repeated hangs with the log showing this:

[debug] [<0.89.0>] Attachment URL http://localhost:5985/acumen-curricula/c16669078d5349503423e44095de25a3/Eng3MainIdea.pdf?rev=31-3046362463
[debug] [<0.89.0>] streaming attachment Status "200" Headers [{"Transfer-Encoding","chunked"},
                                           {"Server",
                                            "CouchDB/0.10.0a (Erlang OTP/R13B)"},
                                           {"ETag","\"31-3046362463\""},
                                           {"Date",
                                            "Thu, 28 May 2009 22:11:11 GMT"},
                                           {"Content-Type","application/pdf"},
                                           {"Cache-Control",
                                            "must-revalidate"}]
[debug] [<0.89.0>] ProcessMem 56738000 BinaryMem 24014824
[debug] [<0.89.0>] ProcessMem 32203508 BinaryMem 2156534

but each time at a different point. This may well be unrelated, but I'm not sure.


> Replication hangs and won't restart
> -----------------------------------
>
>                 Key: COUCHDB-365
>                 URL: https://issues.apache.org/jira/browse/COUCHDB-365
>             Project: CouchDB
>          Issue Type: Bug
>          Components: Database Core
>    Affects Versions: 0.9.1
>         Environment: Replicate to Ubuntu from OSX, both running R13B
>            Reporter: Antony Blakey
>
> Partway through a replication I get this:
>   {"error":"json_encode","reason":"{bad_term,{couch_rep,'-memory_footprint/1-fun-0-',2}}"}
> as the response from the replication request. Attempting to restart replication results
in:
>   [info] [<0.5511.0>] replication "1f78d088910dc73016c0b16b2fb84aac" already running
at <0.4203.0>
> but the replication has hung.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message