couchdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mikeal Rogers <mikeal.rog...@gmail.com>
Subject Re: JavaScript 1.8 Features in SpiderMonkey (Please?)
Date Mon, 23 Mar 2009 18:44:31 GMT
MacPorts is at 1.7

http://spidermonkey.darwinports.com/

I can't tell if apt is at 1.8 or 1.9

http://packages.debian.org/sid/libmozjs1d
http://packages.debian.org/sid/libnspr4-0d

FreeBSD Ports is at 1.7

http://www.freebsd.org/cgi/cvsweb.cgi/ports/lang/spidermonkey/

-Mikeal

On Mar 23, 2009, at March 23, 200911:34 AM, Paul Davis wrote:

> On Mon, Mar 23, 2009 at 2:23 PM, Zachary Zolton
> <zachary.zolton@gmail.com> wrote:
>> Hi,
>>
>> The functional features in JavaScript 1.8 could greatly aid  
>> developers
>> when writing map-reduce functions for views.
>>
>> Does anyone oppose upping the language version? If so, I'd appreciate
>> hearing their reasons.
>>
>
> I don't think it'd be a good idea to require until it hits general
> consumption (as in, shows up in package managers). Their build
> procedure is at best, 'interesting'. Also, there's nothing to keep you
> from linking couchjs against a newer version of the library. I haven't
> groked all of the API breakage but there was a report on the list
> awhile back that seemed to indicate that it only involved a minor
> patch.
>
> HTH,
> Paul Davis
>
>>
>> Thank you,
>>
>> Zach
>>


Mime
View raw message