couchdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jan Lehnardt <>
Subject Re: Stats
Date Mon, 23 Feb 2009 14:51:51 GMT

On 22 Feb 2009, at 15:06, Jan Lehnardt wrote:
> I mentioned this in an earlier mail but I'd like to bring it up again,
> since your input is needed here. Metrics are identified with a
> tuple `{Module, Key}`. `Module` is the module that initiates the
> counting of the metric and `Key` is a uniquely identifies a metric
> within a module. Until now, Alex and I just made up names as
> they came up without much considering a consistent and intuitive
> naming scheme. It would be great if you could help out checking
> if the names are any good and suggest alternatives.

So far we have:

{couchdb, open_databases}
{couchdb, request_time}

{httpd, bulk_requests}
{httpd, head_requests}
{httpd, get_requests}
{httpd, put_requests}
{httpd, post_requests}
{httpd, delete_requests}
{httpd, copy_requests}
{httpd, move_requests}

{httpd, document_copies}
{httpd, document_creates}
{httpd, document_deletes}
{httpd, document_moves}
{httpd, document_reads}
{httpd, document_updates}
{httpd, requests}
{httpd, temporary_view_reads}
{httpd, view_reads}

{http_status_codes, Code} (Code is one of 200, 201, 203 ... )

I'd suggest
  - to move the `document_*` keys from `httpd` to `couchdb`,
  - to rename `httpd` to `http`.

Is there anything else that you think should look different?


View raw message