couchdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Damien Katz <dam...@apache.org>
Subject Re: Stats
Date Tue, 24 Feb 2009 17:34:29 GMT

On Feb 23, 2009, at 9:51 AM, Jan Lehnardt wrote:

>
> On 22 Feb 2009, at 15:06, Jan Lehnardt wrote:
>> I mentioned this in an earlier mail but I'd like to bring it up  
>> again,
>> since your input is needed here. Metrics are identified with a
>> tuple `{Module, Key}`. `Module` is the module that initiates the
>> counting of the metric and `Key` is a uniquely identifies a metric
>> within a module. Until now, Alex and I just made up names as
>> they came up without much considering a consistent and intuitive
>> naming scheme. It would be great if you could help out checking
>> if the names are any good and suggest alternatives.
>
> So far we have:
>
> {couchdb, open_databases}
> {couchdb, request_time}
>
> {httpd, bulk_requests}
> {httpd, head_requests}
> {httpd, get_requests}
> {httpd, put_requests}
> {httpd, post_requests}
> {httpd, delete_requests}
> {httpd, copy_requests}
> {httpd, move_requests}
>
> {httpd, document_copies}
> {httpd, document_creates}
> {httpd, document_deletes}
> {httpd, document_moves}
> {httpd, document_reads}
> {httpd, document_updates}
> {httpd, requests}
> {httpd, temporary_view_reads}
> {httpd, view_reads}
>
> {http_status_codes, Code} (Code is one of 200, 201, 203 ... )
>
>
> I'd suggest
> - to move the `document_*` keys from `httpd` to `couchdb`,

Yes.

>
> - to rename `httpd` to `http`.

I think because replication also makes http requests, it should stay  
as is.

>
>
> Is there anything else that you think should look different?
>
>

MOVE and COPY should be httpd stats, and shouldn't be tracked at the   
db level, except as the underlying create and deletion stats.

-Damien


Mime
View raw message