couchdb-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From kxe...@apache.org
Subject couchdb commit: updated refs/heads/master to 333c19a
Date Thu, 21 May 2015 19:14:05 GMT
Repository: couchdb
Updated Branches:
  refs/heads/master 8a4c7912a -> 333c19ae1


Fix documentation to add package libkjsapi4

The current documentation doesn't ask to install package
libkjsapi4 as a dependency, which causes the following problem:

 Compiling /home/ubuntu/Devel/couchdb/src/couch/priv/couch_js/http.c
 /home/ubuntu/Devel/couchdb/src/couch/priv/couch_js/http.c:18:19: fatal error: jsapi.h: No
such file or directory
  #include <jsapi.h>
                   ^
 compilation terminated.
 ERROR: compile failed while processing /home/ubuntu/Devel/couchdb/src/couch: rebar_abort
 Makefile:22: recipe for target 'couch' failed
 make: *** [couch] Error 1

This patch just fix the documentation and adds the package as a
dependency.


Project: http://git-wip-us.apache.org/repos/asf/couchdb/repo
Commit: http://git-wip-us.apache.org/repos/asf/couchdb/commit/333c19ae
Tree: http://git-wip-us.apache.org/repos/asf/couchdb/tree/333c19ae
Diff: http://git-wip-us.apache.org/repos/asf/couchdb/diff/333c19ae

Branch: refs/heads/master
Commit: 333c19ae194332d21759b088967a9890fcc3f00f
Parents: 8a4c791
Author: Breno Leitao <breno.leitao@gmail.com>
Authored: Thu May 21 15:00:23 2015 -0400
Committer: Breno Leitao <breno.leitao@gmail.com>
Committed: Thu May 21 15:00:23 2015 -0400

----------------------------------------------------------------------
 INSTALL.Unix | 1 +
 1 file changed, 1 insertion(+)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/couchdb/blob/333c19ae/INSTALL.Unix
----------------------------------------------------------------------
diff --git a/INSTALL.Unix b/INSTALL.Unix
index f662e63..6483b7c 100644
--- a/INSTALL.Unix
+++ b/INSTALL.Unix
@@ -72,6 +72,7 @@ You can install the dependencies by running:
     sudo apt-get install libcurl4-openssl-dev
     sudo apt-get install pkg-config
     sudo apt-get install rebar
+    sudo apt-get install libkjsapi4
 
 There are lots of Erlang packages. If there is a problem with your
 install, try a different mix. There is more information on the


Mime
View raw message