couchdb-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From wenda...@apache.org
Subject couchdb commit: updated refs/heads/1.6.x to f5e5b37
Date Tue, 29 Apr 2014 21:39:06 GMT
Repository: couchdb
Updated Branches:
  refs/heads/1.6.x 9f65fbe8c -> f5e5b37fa


Added missing build requirements for Centos/RHEL environments.


Project: http://git-wip-us.apache.org/repos/asf/couchdb/repo
Commit: http://git-wip-us.apache.org/repos/asf/couchdb/commit/f5e5b37f
Tree: http://git-wip-us.apache.org/repos/asf/couchdb/tree/f5e5b37f
Diff: http://git-wip-us.apache.org/repos/asf/couchdb/diff/f5e5b37f

Branch: refs/heads/1.6.x
Commit: f5e5b37faf12b2388ae1ce03209dc6a53a868f33
Parents: 9f65fbe
Author: Wendall Cada <wendallc@83864.com>
Authored: Tue Apr 29 14:35:38 2014 -0700
Committer: Wendall Cada <wendallc@83864.com>
Committed: Tue Apr 29 14:37:23 2014 -0700

----------------------------------------------------------------------
 INSTALL.Unix                   | 16 ++++++++--------
 share/doc/src/install/unix.rst | 15 ++++++++-------
 2 files changed, 16 insertions(+), 15 deletions(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/couchdb/blob/f5e5b37f/INSTALL.Unix
----------------------------------------------------------------------
diff --git a/INSTALL.Unix b/INSTALL.Unix
index a070558..965bb34 100644
--- a/INSTALL.Unix
+++ b/INSTALL.Unix
@@ -94,20 +94,20 @@ RedHat-based (Fedora, Centos, RHEL) Systems
 
 You can install the dependencies by running:
 
-    sudo yum groupinstall "Development Tools"
     sudo yum install autoconf
     sudo yum install autoconf-archive
     sudo yum install automake
-    sudo yum install libtool
-    sudo yum install perl-Test-Harness
-    sudo yum install erlang-etap
+    sudo yum install curl-devel
+    sudo yum install erlang-asn1
     sudo yum install erlang-erts
-    sudo yum install erlang-os_mon
     sudo yum install erlang-eunit
-    sudo yum install libicu-devel
+    sudo yum install erlang-os_mon
+    sudo yum install erlang-xmerl
+    sudo yum install help2man
     sudo yum install js-devel
-    sudo yum install curl-devel
-    sudo yum install pkg-config
+    sudo yum install libicu-devel
+    sudo yum install libtool
+    sudo yum install perl-Test-Harness
 
 While CouchDB builds against the default js-devel-1.7.0 included in
 some distributions, it's recommended to use a more recent

http://git-wip-us.apache.org/repos/asf/couchdb/blob/f5e5b37f/share/doc/src/install/unix.rst
----------------------------------------------------------------------
diff --git a/share/doc/src/install/unix.rst b/share/doc/src/install/unix.rst
index 05e0459..9c1084c 100644
--- a/share/doc/src/install/unix.rst
+++ b/share/doc/src/install/unix.rst
@@ -102,19 +102,20 @@ RedHat-based (Fedora, Centos, RHEL) Systems
 
 You can install the dependencies by running::
 
-    sudo yum groupinstall "Development Tools"
     sudo yum install autoconf
     sudo yum install autoconf-archive
     sudo yum install automake
-    sudo yum install libtool
-    sudo yum install perl-Test-Harness
-    sudo yum install erlang-etap
+    sudo yum install curl-devel
+    sudo yum install erlang-asn1
     sudo yum install erlang-erts
-    sudo yum install erlang-os_mon
     sudo yum install erlang-eunit
-    sudo yum install libicu-devel
+    sudo yum install erlang-os_mon
+    sudo yum install erlang-xmerl
+    sudo yum install help2man
     sudo yum install js-devel
-    sudo yum install curl-devel
+    sudo yum install libicu-devel
+    sudo yum install libtool
+    sudo yum install perl-Test-Harness
 
 While CouchDB builds against the default js-devel-1.7.0 included in some
 distributions, it's recommended to use a more recent js-devel-1.8.5.


Mime
View raw message