couchdb-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From rnew...@apache.org
Subject [21/50] git commit: Tweaked required version of Autoconf
Date Sun, 18 Nov 2012 16:56:23 GMT
Tweaked required version of Autoconf


Project: http://git-wip-us.apache.org/repos/asf/couchdb/repo
Commit: http://git-wip-us.apache.org/repos/asf/couchdb/commit/d98d19f3
Tree: http://git-wip-us.apache.org/repos/asf/couchdb/tree/d98d19f3
Diff: http://git-wip-us.apache.org/repos/asf/couchdb/diff/d98d19f3

Branch: refs/heads/docs
Commit: d98d19f3adf4762616d439b78db99d502c20ce6d
Parents: efd5e7b
Author: Noah Slater <nslater@apache.org>
Authored: Sun Oct 14 13:35:21 2012 +0100
Committer: Robert Newson <rnewson@apache.org>
Committed: Sun Nov 18 00:15:31 2012 +0000

----------------------------------------------------------------------
 DEVELOPERS   |   16 +++++++++++-----
 configure.ac |    2 +-
 2 files changed, 12 insertions(+), 6 deletions(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/couchdb/blob/d98d19f3/DEVELOPERS
----------------------------------------------------------------------
diff --git a/DEVELOPERS b/DEVELOPERS
index 8c45a24..a77bf8e 100644
--- a/DEVELOPERS
+++ b/DEVELOPERS
@@ -10,9 +10,11 @@ Dependencies
 
 You will need the following installed:
 
- * GNU Automake (>=1.6.3) (http://www.gnu.org/software/automake/)
- * GNU Autoconf (>=2.59)  (http://www.gnu.org/software/autoconf/)
  * GNU Libtool            (http://www.gnu.org/software/libtool/)
+ * GNU Automake (>=1.6.3) (http://www.gnu.org/software/automake/)
+ * GNU Autoconf (>=2.68)  (http://www.gnu.org/software/autoconf/)
+ * GNU Autoconf Archive   (http://www.gnu.org/software/autoconf-archive/)
+ * pkg-config             (http://www.freedesktop.org/wiki/Software/pkg-config)
  * GNU help2man           (http://www.gnu.org/software/help2man/)
 
 # @@ pkg-config
@@ -28,7 +30,7 @@ Debian-based (inc. Ubuntu) Systems
 
 You can install the dependencies by running:
 
-    apt-get install automake autoconf libtool help2man
+    apt-get install libtool automake autoconf autoconf-archive pkg-config help2man
 
 Be sure to update the version numbers to match your system's available packages.
 
@@ -37,9 +39,13 @@ Mac OS X
 
 You can install the dependencies by running:
 
-    port install automake autoconf libtool help2man
+    brew install libtool automake autoconf autoconf-archive pkg-config help2man
+
+# @@ check these packages are correct
+
+# @@ check other files don't use MacPorts
 
-You will need MacPorts installed to use the `port` command.
+You will need Homebrew installed to use the `brew` command.
 
 Bootstrapping
 -------------

http://git-wip-us.apache.org/repos/asf/couchdb/blob/d98d19f3/configure.ac
----------------------------------------------------------------------
diff --git a/configure.ac b/configure.ac
index 8d9c749..c27bc59 100644
--- a/configure.ac
+++ b/configure.ac
@@ -16,7 +16,7 @@ AC_INIT(
     [LOCAL_BUG_URI],
     [LOCAL_PACKAGE_TARNAME])
 
-AC_PREREQ([2.69])
+AC_PREREQ([2.68])
 
 AC_CONFIG_SRCDIR([CHANGES])
 AC_CONFIG_AUX_DIR([build-aux])


Mime
View raw message