couchdb-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From d..@apache.org
Subject [2/2] git commit: Docs: update README and INSTALL.* for Sphinx & 1.3.x
Date Mon, 01 Oct 2012 13:43:11 GMT
Docs: update README and INSTALL.* for Sphinx & 1.3.x


Project: http://git-wip-us.apache.org/repos/asf/couchdb/repo
Commit: http://git-wip-us.apache.org/repos/asf/couchdb/commit/d0225587
Tree: http://git-wip-us.apache.org/repos/asf/couchdb/tree/d0225587
Diff: http://git-wip-us.apache.org/repos/asf/couchdb/diff/d0225587

Branch: refs/heads/docs
Commit: d02255878aaaa630d9d5489edacf526939495368
Parents: a0d2f83
Author: Dave Cottlehuber <dch@apache.org>
Authored: Mon Oct 1 10:48:26 2012 +0200
Committer: Dave Cottlehuber <dch@apache.org>
Committed: Mon Oct 1 10:48:26 2012 +0200

----------------------------------------------------------------------
 INSTALL.Unix    |    7 +++++--
 INSTALL.Windows |   35 +++++++++++++++++++++++------------
 2 files changed, 28 insertions(+), 14 deletions(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/couchdb/blob/d0225587/INSTALL.Unix
----------------------------------------------------------------------
diff --git a/INSTALL.Unix b/INSTALL.Unix
index baf9d06..d1dfb0f 100644
--- a/INSTALL.Unix
+++ b/INSTALL.Unix
@@ -33,10 +33,13 @@ You should have the following installed:
  * GNU Compiler Collection    (http://gcc.gnu.org/)
  * libcurl                    (http://curl.haxx.se/libcurl/)
  * help2man                   (http://www.gnu.org/s/help2man/)
+ * Python (>= 2.7) for docs   (http://python.org/)
+ * Python Sphinx (>=1.1.3)    (http://pypi.python.org/pypi/Sphinx)
 
-It is recommended that you install Erlang OTP R12B-5 or above where possible.
-You will only need libcurl if you plan to run the JavaScript test suite. And
+It is recommended that you install Erlang OTP R13B04 or above where possible.
+You will only need libcurl if you plan to run the JavaScript test suite.
 help2man is only need if you plan on installing the CouchDB man pages.
+Python and Sphinx are only required for building the online documentation.
 
 Ubuntu
 ~~~~~~

http://git-wip-us.apache.org/repos/asf/couchdb/blob/d0225587/INSTALL.Windows
----------------------------------------------------------------------
diff --git a/INSTALL.Windows b/INSTALL.Windows
index b75b80a..a503def 100644
--- a/INSTALL.Windows
+++ b/INSTALL.Windows
@@ -14,6 +14,10 @@ There is a wiki for general documentation:
 
     http://wiki.apache.org/couchdb/
 
+And some Windows-specific tips:
+
+    http://wiki.apache.org/couchdb/Quirks_on_Windows
+
 There are collection of friendly mailing lists:
 
     http://couchdb.apache.org/community/lists.html
@@ -25,28 +29,35 @@ Dependencies
 
 You will need the following installed:
 
- * Erlang OTP (=14B01)        (http://erlang.org/)
- * ICU        (=4.4.*)         (http://icu.sourceforge.net/)
- * OpenSSL                    (http://www.openssl.org/)
- * Mozilla SpiderMonkey (1.7) (http://www.mozilla.org/js/spidermonkey/)
- * libcurl                    (http://curl.haxx.se/libcurl/)
- * Cygwin                     (http://www.cygwin.com/)
- * Visual Studio 2008         (http://msdn.microsoft.com/en-gb/vstudio/default.aspx)
+ * Erlang OTP (>=14B01)          (http://erlang.org/)
+ * ICU        (>=4.*)            (http://icu.sourceforge.net/)
+ * OpenSSL    (>=0.9.8r)         (http://www.openssl.org/)
+ * Mozilla SpiderMonkey (=1.8.5) (http://www.mozilla.org/js/spidermonkey/)
+ * libcurl                       (http://curl.haxx.se/libcurl/)
+ * Cygwin                        (http://www.cygwin.com/)
+ * Microsoft SDK 7.0 or 7.1      (http://www.microsoft.com/en-us/download/details.aspx?id=8279)
+ * Python (>= 2.7) for docs      (http://python.org/)
+ * Python Sphinx (>=1.1.3)       (http://pypi.python.org/pypi/Sphinx)
 
 General Notes
 -------------
 
+ * When installing Cygwin, be sure to select all the `development` tools.
+
  * When installing Erlang, you must build it from source.
 
-   The CouchDB build requires a number of the Erlang build scripts.
+ * The CouchDB build requires a number of the Erlang build scripts.
 
- * When installing ICU, select the binaries built with Visual Studio 2008.
+ * All dependent libraries should be built with the same version of
+   microsoft SDK.
 
- * When installing Cygwin, be sure to select all the `development` tools.
+ * Do not try to link against libraries built with, or included in,
+   Cygwin or MingW. They are not compatible with the Erlang/OTP or CouchDB
+   build scripts.
 
- * When installing libcurl, be sure to install by hand.
+ * ICU version 4.6 and later will build cleanly using MSBuild.
 
-   The Cygwin binaries are incompatible and will not work with Erlang.
+ * Python and Sphinx are only required for building the online documentation.
 
 Setting Up Cygwin
 -----------------


Mime
View raw message