couchdb-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Apache Wiki <wikidi...@apache.org>
Subject [Couchdb Wiki] Update of "Installing_on_Ubuntu" by OctavianDamiean
Date Mon, 23 Jul 2012 21:02:57 GMT
Dear Wiki user,

You have subscribed to a wiki page or wiki category on "Couchdb Wiki" for change notification.

The "Installing_on_Ubuntu" page has been changed by OctavianDamiean:
http://wiki.apache.org/couchdb/Installing_on_Ubuntu?action=diff&rev1=75&rev2=76

Comment:
replaced Synaptics mentions with Ubuntu Software Center as it was outdated, used apt-get in
the installation example instead of aptitude and updated version mentions to 1.2.0

  <<Include(EditTheWiki)>>
  
  == Batteries Included ==
- Newer versions of Ubuntu have CouchDB  included in their respective software repositories.
 You can install CouchDB with the '''Synaptic GUI''', or from the command line with the '''apt-get'''
or '''aptitude''' utilities, which ever you prefer.  However, to get the newest version of
CouchDB you may have to install from source, or other package repositories that have newer
pre-built CouchDB packages.
+ Newer versions of Ubuntu have CouchDB  included in their respective software repositories.
 You can install CouchDB with the '''Ubuntu Software Center''', or from the command line with
the '''apt-get''' or '''aptitude''' utilities, which ever you prefer.  However, to get the
newest version of CouchDB you may have to install from source, or other package repositories
that have newer pre-built CouchDB packages.
  
- As of July 2011 modern package repositories only have CouchDB v1.0.x and not v1.1, which
is highly recommend over 1.0.x. To install 1.1 please see the build-couchdb section below.
+ As of July 2012 modern package repositories only have [[https://apps.ubuntu.com/cat/applications/precise/couchdb/|CouchDB
v1.0.1]] and not v1.2.0, which is highly recommend over 1.0.1. To install 1.2.0 please see
the build-couchdb section below.
  
  {{{
- sudo aptitude install couchdb
+ sudo apt-get install couchdb
  }}}
  === Troubleshooting ===
  If the aptitude/apt-get installation gives an error message then couchdb might not have
access to its pid file.
@@ -60, +60 @@

   * To be thorough, you should run the built in tests to ensure that CouchDB is working properly.
 To '''run the tests''', click on the [[http://localhost:5984/_utils/couch_tests.html?script/couch_tests.js|Test
Suite]] link on the right hand side of the Futon Web GUI, then click on "Run All" to execute
all of the built in tests.  ''All of tests should run without error on Ubuntu.''
   * Once CouchDB is working properly you can add CouchDB to your startup scripts if desired.
  
- Note: If you installed all the dependencies of Couchdb from the Synaptic GUI, but not CouchDB
itself, some of the dependencies may think they are not required and the update manager may
suggest that they are removed. Should you remove these dependencies, CouchDB may fail to start,
perhaps with an error such as:
+ ''Note: If you installed all the dependencies of CouchDB from the Ubuntu Software Center,
but not CouchDB itself, some of the dependencies may think they are not required and the update
manager may suggest that they are removed. Should you remove these dependencies, CouchDB may
fail to start, perhaps with an error such as:''
  
  {{{
  {"init terminating in do_boot",{undef,[{crypto,start,[]},{erl_eval,do_apply,5},{init,start_it,1},{init,start_em,1}]}}
  }}}
+ 
- If this happens simply re-install the dependencies (possibly erlang-nox but it could vary)
+ If this happens simply re-install the dependencies (possibly erlang-nox but it could vary).
  
  === Example 1 ===
  Please see below in links for complete instructions on how to install CouchDB.

Mime
View raw message