couchdb-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From rand...@apache.org
Subject svn commit: r1133272 - in /couchdb/branches/1.1.x: INSTALL.Unix configure.ac src/couchdb/couch_app.erl src/erlang-oauth/Makefile.am
Date Wed, 08 Jun 2011 07:53:55 GMT
Author: randall
Date: Wed Jun  8 07:53:55 2011
New Revision: 1133272

URL: http://svn.apache.org/viewvc?rev=1133272&view=rev
Log:
bump minimum erlang to R13B02 (COUCHDB-1191)

Modified:
    couchdb/branches/1.1.x/INSTALL.Unix
    couchdb/branches/1.1.x/configure.ac
    couchdb/branches/1.1.x/src/couchdb/couch_app.erl
    couchdb/branches/1.1.x/src/erlang-oauth/Makefile.am

Modified: couchdb/branches/1.1.x/INSTALL.Unix
URL: http://svn.apache.org/viewvc/couchdb/branches/1.1.x/INSTALL.Unix?rev=1133272&r1=1133271&r2=1133272&view=diff
==============================================================================
--- couchdb/branches/1.1.x/INSTALL.Unix (original)
+++ couchdb/branches/1.1.x/INSTALL.Unix Wed Jun  8 07:53:55 2011
@@ -8,7 +8,7 @@ Dependencies
 
 You will need the following installed:
 
- * Erlang OTP (>=R12B5)       (http://erlang.org/)
+ * Erlang OTP (>=R13B2)       (http://erlang.org/)
  * ICU                        (http://icu.sourceforge.net/)
  * OpenSSL                    (http://www.openssl.org/)
  * Mozilla SpiderMonkey (1.8) (http://www.mozilla.org/js/spidermonkey/)

Modified: couchdb/branches/1.1.x/configure.ac
URL: http://svn.apache.org/viewvc/couchdb/branches/1.1.x/configure.ac?rev=1133272&r1=1133271&r2=1133272&view=diff
==============================================================================
--- couchdb/branches/1.1.x/configure.ac (original)
+++ couchdb/branches/1.1.x/configure.ac Wed Jun  8 07:53:55 2011
@@ -241,7 +241,7 @@ if test x${ERL} = x; then
     AC_MSG_ERROR([Could not find the `erl' executable. Is Erlang installed?])
 fi
 
-erlang_version_error="The installed Erlang version is less than 5.6.5 (R12B05)."
+erlang_version_error="The installed Erlang version is less than erts-5.7.3 (R13B02)."
 
 version="`${ERL} -version 2>&1 | ${SED} "s/[[^0-9]]/ /g"`"
 
@@ -249,12 +249,12 @@ if test `echo $version | ${AWK} "{print 
     AC_MSG_ERROR([$erlang_version_error])
 fi
 
-if test `echo $version | ${AWK} "{print \\$2}"` -lt 6; then
+if test `echo $version | ${AWK} "{print \\$2}"` -lt 7; then
     AC_MSG_ERROR([$erlang_version_error])
 fi
 
-if test `echo $version | ${AWK} "{print \\$2}"` -eq 6; then
-    if test `echo $version | ${AWK} "{print \\$3}"` -lt 5; then
+if test `echo $version | ${AWK} "{print \\$2}"` -eq 7; then
+    if test `echo $version | ${AWK} "{print \\$3}"` -lt 3; then
         AC_MSG_ERROR([$erlang_version_error])
     fi
 fi

Modified: couchdb/branches/1.1.x/src/couchdb/couch_app.erl
URL: http://svn.apache.org/viewvc/couchdb/branches/1.1.x/src/couchdb/couch_app.erl?rev=1133272&r1=1133271&r2=1133272&view=diff
==============================================================================
--- couchdb/branches/1.1.x/src/couchdb/couch_app.erl (original)
+++ couchdb/branches/1.1.x/src/couchdb/couch_app.erl Wed Jun  8 07:53:55 2011
@@ -48,9 +48,6 @@ start_apps([App|Rest]) ->
        start_apps(Rest);
     {error, {already_started, App}} ->
        start_apps(Rest);
-    {error, _Reason} when App =:= public_key ->
-       % ignore on R12B5
-       start_apps(Rest);
     {error, _Reason} ->
        {error, {app_would_not_start, App}}
     end.

Modified: couchdb/branches/1.1.x/src/erlang-oauth/Makefile.am
URL: http://svn.apache.org/viewvc/couchdb/branches/1.1.x/src/erlang-oauth/Makefile.am?rev=1133272&r1=1133271&r2=1133272&view=diff
==============================================================================
--- couchdb/branches/1.1.x/src/erlang-oauth/Makefile.am (original)
+++ couchdb/branches/1.1.x/src/erlang-oauth/Makefile.am Wed Jun  8 07:53:55 2011
@@ -22,15 +22,13 @@ oauth_file_collection = \
     oauth_unix.erl \
     oauth_uri.erl
 
-# Removed oauth_rsa_sha1.beam until we require R12B5 or
-# we add a ./configure option to enable it.
-
 oauthebin_make_generated_file_list = \
 	oauth.app \
     oauth.beam \
     oauth_hmac_sha1.beam \
     oauth_http.beam \
     oauth_plaintext.beam \
+    oauth_rsa_sha1.erl \
     oauth_unix.beam \
     oauth_uri.beam
 



Mime
View raw message