couchdb-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Apache Wiki <wikidi...@apache.org>
Subject [Couchdb Wiki] Trivial Update of "Running CouchDB in Dev Mode" by RogerBinns
Date Sat, 02 Jan 2010 04:27:23 GMT
Dear Wiki user,

You have subscribed to a wiki page or wiki category on "Couchdb Wiki" for change notification.

The "Running CouchDB in Dev Mode" page has been changed by RogerBinns.
The comment on this change is: Ubuntu 9.10 now uses xulrunner 1.9.1.6.
http://wiki.apache.org/couchdb/Running%20CouchDB%20in%20Dev%20Mode?action=diff&rev1=6&rev2=7

--------------------------------------------------

  {{{
  $ utils/run -help
  }}}
- 
  === Ubuntu 9.10 ===
- 
  This is how you can run the dev version side by side with the Ubuntu version. The main difficulties
are Javascript engine paths as documented by [[http://mattgoodall.blogspot.com/2009/09/build-couchdb-on-ubuntu-910-karmic.html|Matt
Goodall]].  You need to specify `LD_RUN_PATH=/usr/lib/xulrunner-1.9.1.5` before every command
as well as provide extra parameters to configure.
  
  Get all the needed build time packages:
@@ -44, +42 @@

  {{{
  $ sudo apt-get install libtool help2man erlang-nox erlang-dev libicu-dev xulrunner-dev libcurl4-openssl-dev
build-essential
  }}}
+ Checkout source code and build it:
  
- Checkout source code and build it:
  {{{
  $ svn co http://svn.apache.org/repos/asf/couchdb/trunk couchdb
  $ cd couchdb
  $ ./bootstrap
- $ LD_RUN_PATH=/usr/lib/xulrunner-1.9.1.5 ./configure --with-js-lib=/usr/lib/xulrunner-devel-1.9.1.5/lib/
--with-js-include=/usr/lib/xulrunner-devel-1.9.1.5/include
+ $ LD_RUN_PATH=/usr/lib/xulrunner-1.9.1.6 ./configure --with-js-lib=/usr/lib/xulrunner-devel-1.9.1.6/lib/
--with-js-include=/usr/lib/xulrunner-devel-1.9.1.6/include
- $ LD_RUN_PATH=/usr/lib/xulrunner-1.9.1.5 make dev
+ $ LD_RUN_PATH=/usr/lib/xulrunner-1.9.1.6 make dev
  }}}
- 
  Now edit `./etc/default/local_dev.ini` and change the port.  I use 5984 (default) for the
Ubuntu install and 5985 for this dev version.
  
  {{{
- $ LD_RUN_PATH=/usr/lib/xulrunner-1.9.1.5 utils/run
+ $ LD_RUN_PATH=/usr/lib/xulrunner-1.9.1.6 utils/run
  }}}
  

Mime
View raw message