couchdb-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Apache Wiki <wikidi...@apache.org>
Subject [Couchdb Wiki] Update of "Installing on OSX" by PaulDavis
Date Mon, 14 Sep 2009 00:46:23 GMT
Dear Wiki user,

You have subscribed to a wiki page or wiki category on "Couchdb Wiki" for change notification.

The following page has been changed by PaulDavis:
http://wiki.apache.org/couchdb/Installing_on_OSX

------------------------------------------------------------------------------
  $ make install
  }}}
  
- 2) Install SpiderMonkey
+ 2. Install SpiderMonkey
  
  We need [http://svn.macports.org/repository/macports/trunk/dports/lang/spidermonkey/files/patch-jsprf.c
jsprf patch ] from the MacPorts project to install SpiderMonkey. 
- 
- 
  
  {{{
  $ curl -O http://ftp.mozilla.org/pub/mozilla.org/js/js-1.7.0.tar.gz
@@ -88, +86 @@

  $ sudo ranlib /usr/local/spidermonkey/lib/libjs.a
  }}}
  
+ ==== Using DYLD_LIBRARY_PATH ====
+ 
  add to your .profile this line :
  {{{
  export DYLD_LIBRARY_PATH=$DYLD_LIBRARY_PATH:/usr/local/spidermonkey/lib
@@ -99, +99 @@

  $ . ~/.profile
  }}}
  
+ ==== Avoding DYLD_LIBRARY_PATH ====
+ 
+ Not using DYLD_LIBRARY_PATH means that you don't need to worry about setting the environment
for other users (ie, the couchdb user or root). Also, it avoids the need to tell the CouchDB
./configure script where to find spidermonkey.
+ 
+ {{{
+ $ sudo ln -s /usr/local/spidermonkey/include /usr/local/include/js
+ $ sudo ln -s /usr/local/spdiermonkey/lib/libjs.dyld /usr/local/lib/libjs.dyld
+ # If you're feeling saucey, the js shell can be useful for quick syntax checking and the
like.
+ $ sudo ln -s /usr/local/spidermonkey/bin/js /usr/local/bin/js
+ }}}
+ 
- 3) Install Erlang R13B01
+ 3. Install Erlang R13B01
  
  {{{
  $ curl -O http://erlang.org/download/otp_src_R13B01.tar.gz
@@ -111, +122 @@

  
  }}}
  
- 4) Finally, install CouchDB:
+ 4. Building CouchDB:
  
  We will install it from the trunk, but installation from released source should work
  
@@ -122, +133 @@

  $ make
  }}}
  
+ ==== NOTE ====
+ 
+ If you avoided using DYLD_LIBRARY_PATH when installing spidermonkey, you won't need to use
the --with-js-[include|lib] flags.
+ 
+ 5. Running
+ 
  If you want to install run `make install` . For developement use do :
  
  {{{

Mime
View raw message