corinthia-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gabriela Gibson <gabriela.gib...@gmail.com>
Subject Re: Operations.c: DFGet() called from consumers/dfconvert/main.c
Date Mon, 04 May 2015 13:39:34 GMT
On Mon, May 4, 2015 at 2:09 PM, Franz de Copenhague <
franzdecopenhague@outlook.com> wrote:

> ----------------------------------------
> > Date: Mon, 4 May 2015 07:59:31 +0200
> > Subject: Re: Operations.c: DFGet() called from consumers/dfconvert/main.c
> > From: jani@apache.org
> > To: dev@corinthia.incubator.apache.org
> >
> > On Monday, May 4, 2015, Gabriela Gibson <gabriela.gibson@gmail.com>
> wrote:
> >
> >>
> >> I also would like to rename int r = 0; to the (a little more obvious)
> int
> >> success = 0;
> >>
> >> What do you think?
> >
> > sounds logical to me.
>
> To keep the semantics you can do r = SUCCESS instead of r = 0; and define
> SUCCESS somewhere
>
> That would be a global decision --- and I think quite a good one, since
this kind of pattern will come up a number of times in the code and it's
nice to have uniformity.

I'm not sure in which header file this would live in, so that it can be
found everywhere.

What does everyone think about this?

G






-- 
Visit my Coding Diary: http://gabriela-gibson.blogspot.com/

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message