corinthia-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dennis E. Hamilton" <dennis.hamil...@acm.org>
Subject RE: [REVIEW REQUEST] External Scripts (was RE: My work in january.)
Date Fri, 09 Jan 2015 20:52:12 GMT
I need more information about the mapped drive errors.  See below.

 - Dennis

PS: I am pleased that you find the level of documentation useful.

-----Original Message-----
From: Peter Kelly [mailto:pmkelly@apache.org] 
Sent: Friday, January 9, 2015 08:59
To: dev@corinthia.incubator.apache.org
Subject: Re: [REVIEW REQUEST] External Scripts (was RE: My work in january.)

I’ve just tested this on Windows 7 (SP1), and ran into the following error message:

An unexpected error is keeping you from copying the file. If you continue to receive this
error, you can use the error code to search for help with this problem.

Error 0x80004005: Unspecified error

zconf.h
Type: C/C+ Header
Date modified: 5/13/2013 1:57 PM
Size: 15.1 KB

This happened for the following files:

zconf.h
zlib.h
zdll.lib
zlib.def
example_d.exe
minigzip_d.exe

Now this was when running the file from a mapped network drive - which I normally use for
bulids, since I run Windows under VMWare on my mac (and VMWare’s own folder sharing support
is painfully slow, so I use SMB file sharing from the mac side). So I instead tried copying
the entire Corinthia repository onto the C drive (NTFS), and then extract_downloads.bat ran
without problems.

<orcmid>
  Do you have the console output up until the point these errors 
  were reported?

  It appears that the problem occurs when unzipping the 
  zlib128-dll.zip file to subfolder external\download\T\.  
  This is normally the last one.  Did any of the other extracts 
  work?
</orcmid>

I did run into problems with the build where it was unable to find some files. It’s very
late here and I’m about to call it a night, so I’ll have a look into both problems on
the weekend or early next week - as soon as I can find the time.

<orcmid>
  On building the solution, I get 10 error messages, mainly stemming
  From some #include files not being locatable.  It appears that the
  CMake condition on "Windows" is not working or there is something
  else happening in the generated Visual Studio projects.

  That is with a mingw64 build of CMake 3.0.0.  I am going to retry
  with the native[?] Windows CMake 3.1.0 to see if there is any 
  difference.  

  After that, I will dig deeper into the projects to see if I can
  find exactly where the failed #include operations are happening.
</orcmid>

[ ... ]



Mime
View raw message