cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CB-14026) Android installation requirements are out of date
Date Wed, 18 Jul 2018 10:26:00 GMT

    [ https://issues.apache.org/jira/browse/CB-14026?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16547663#comment-16547663
] 

ASF GitHub Bot commented on CB-14026:
-------------------------------------

janpio closed pull request #836: CB-14026 (android): Update Android SDK instructions
URL: https://github.com/apache/cordova-docs/pull/836
 
 
   

This is a PR merged from a forked repository.
As GitHub hides the original diff on merge, it is displayed below for
the sake of provenance:

As this is a foreign pull request (from a fork), the diff is supplied
below (as it won't show otherwise due to GitHub magic):

diff --git a/www/docs/en/dev/guide/platforms/android/index.md b/www/docs/en/dev/guide/platforms/android/index.md
index 18c321b75..4436d5a4e 100644
--- a/www/docs/en/dev/guide/platforms/android/index.md
+++ b/www/docs/en/dev/guide/platforms/android/index.md
@@ -37,8 +37,8 @@ the CLI, see [Cordova CLI Reference][cli_reference].
 Cordova for Android requires the Android SDK which can be installed
 on OS X, Linux or Windows. See the Android SDK's
 [System Requirements](http://developer.android.com/sdk/index.html#Requirements).
-Cordova's latest Android package supports up to Android [API Level](http://developer.android.com/guide/topics/manifest/uses-sdk-element.html#ApiLevels)
25.
-The supported Android API Levels and Android Versions for the past 
+Cordova's latest Android package supports up to Android [API Level](http://developer.android.com/guide/topics/manifest/uses-sdk-element.html#ApiLevels)
27.
+The supported Android API Levels and Android Versions for the past
 few cordova-android releases can be found in this table:
 
 cordova-android Version | Supported Android API-Levels | Equivalent Android Version
@@ -75,10 +75,10 @@ As of Cordova-Android 6.4.0, [Gradle](https://gradle.org/install/) is
now requir
 
 When installing on Windows, you need to add Gradle to your path, (see [Setting Environment
Variables](#setting-environment-variables))
 
-#### Android SDK
+### Android SDK
 
-Install [Android Studio][android_studio].
-Detailed installation instructions are on Android's developer site.
+Install [Android Studio][android_studio]. Follow the instructions at the linked Android Developer
site to get started.
+Opening Android Studio for the first time will guide you through the process of installing
the Android SDK.
 
 #### Adding SDK Packages
 
@@ -87,14 +87,14 @@ whatever [API level](http://developer.android.com/guide/topics/manifest/uses-sdk
 you wish to target. It is recommended that you install the highest SDK version
 that your version of cordova-android supports (see [Requirements and Support](#requirements-and-support)).
 
-Open the Android SDK Manager (run `sdkmanager` from the terminal)
+Open the Android SDK Manager (`Tools > SDK Manager` in Android Studio, or `sdkmanager`
on the command line),
 and make sure the following are installed:
 
 1. Android Platform SDK for your targeted version of Android
 1. Android SDK build-tools version 19.1.0 or higher
-1. Android Support Repository (found under "Extras")
+1. Android Support Repository (found under the "SDK Tools" tab)
 
-See Android's documentation on [Installing SDK Packages](https://developer.android.com/studio/intro/update.html)
+See Android's documentation on [Installing SDK Packages](https://developer.android.com/studio/intro/update)
 for more details.
 
 ### Setting environment variables


 

----------------------------------------------------------------
This is an automated message from the Apache Git Service.
To respond to the message, please log on GitHub and use the
URL above to go to the specific comment.
 
For queries about this service, please contact Infrastructure at:
users@infra.apache.org


> Android installation requirements are out of date
> -------------------------------------------------
>
>                 Key: CB-14026
>                 URL: https://issues.apache.org/jira/browse/CB-14026
>             Project: Apache Cordova
>          Issue Type: Bug
>          Components: cordova-docs
>            Reporter: Simon MacDonald
>            Priority: Major
>
> In this section of the docs:
> [http://cordova.apache.org/docs/en/latest/guide/platforms/android/index.html#installing-the-requirements]
> we talk about running the sdkmanager from the command line but it is no longer available. 
> We should instead tell the users to run the sdkmanager from Android Studio.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@cordova.apache.org
For additional commands, e-mail: issues-help@cordova.apache.org


Mime
View raw message