cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Florian Pechwitz (JIRA)" <j...@apache.org>
Subject [jira] [Created] (CB-14128) Cordova changes plugin version in package.json
Date Tue, 12 Jun 2018 08:54:00 GMT
Florian Pechwitz created CB-14128:
-------------------------------------

             Summary: Cordova changes plugin version in package.json
                 Key: CB-14128
                 URL: https://issues.apache.org/jira/browse/CB-14128
             Project: Apache Cordova
          Issue Type: Bug
          Components: cordova-cli
    Affects Versions: 8.0.0
         Environment: NodeJS: v8.10.0

npm: 5.6.0

Cordova: 8.0.0
            Reporter: Florian Pechwitz


I observed that Cordova changes the version of plugins in package.json. So if I set a static
version for a plugin in package.json and add a platform (e.g. android), Cordova installs the
correct version but updates the version of the plugin in package.json with a caret(^).

Example:

Before adding a platform the package.json looks like that
{code:java}
[...]
"dependencies": {
  "cordova-plugin-ble-central": "1.1.9"
}
[...]{code}
After adding a platform the package.json looks like that
{code:java}
[...]
"dependencies": {
  "cordova-plugin-ble-central": "^1.1.9"
}
[...]
{code}
and the installed plugin has the version 1.1.9.

The next time after removing my plugins and platforms folder Cordova will install that plugin
in version 1.2.1 because of the caret(^) in package.json.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@cordova.apache.org
For additional commands, e-mail: issues-help@cordova.apache.org


Mime
View raw message