cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Shashwat Tripathi (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CB-13800) Drop pre-KitKat specific code
Date Mon, 19 Mar 2018 06:39:00 GMT

    [ https://issues.apache.org/jira/browse/CB-13800?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16404425#comment-16404425
] 

Shashwat Tripathi commented on CB-13800:
----------------------------------------

Does this mean that value of android-minSdkVersion should be 19 instead of 16 from cordova-android
7.1.0?

<preference name="android-minSdkVersion" value="19"/>

 
I am getting an error since I updated to cordova-android to 7.1.0. On changing minSdk to 19
it works.


Manifest merger failed : uses-sdk:minSdkVersion 16 cannot be smaller than version 19 declared
in library [:CordovaLib] /Users/shashwat/projects/bnforecast-ui/dist-phonegap-android/platforms/android/CordovaLib/build/intermediates/manifests/full/debug/AndroidManifest.xml
as the library might be using APIs not available in 16
 Suggestion: use a compatible library with a minSdk of at most 16,
 or increase this project's minSdk version to at least 19,
 or use tools:overrideLibrary="org.apache.cordova" to force usage (may lead to runtime failures)

> Drop pre-KitKat specific code
> -----------------------------
>
>                 Key: CB-13800
>                 URL: https://issues.apache.org/jira/browse/CB-13800
>             Project: Apache Cordova
>          Issue Type: Improvement
>          Components: cordova-android
>    Affects Versions: 7.0.0
>            Reporter: Bas Bosman
>            Assignee: Bas Bosman
>            Priority: Minor
>
> With the release of cordova-android 7.0.0 the minimum API-Level was set to 19.
>  
> There are a couple of places in the codebase where we have specific logic for older API-levels,
which are now no longer needed and therefore can be removed.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@cordova.apache.org
For additional commands, e-mail: issues-help@cordova.apache.org


Mime
View raw message