cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CB-13400) Restructure and test "Installing" instructions
Date Mon, 05 Mar 2018 20:13:00 GMT

    [ https://issues.apache.org/jira/browse/CB-13400?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16386681#comment-16386681
] 

ASF GitHub Bot commented on CB-13400:
-------------------------------------

janpio closed pull request #802: CB-13400 Restructure and test "Installing" instructions(part
b) - Categorizing installation steps according to OSes
URL: https://github.com/apache/cordova-docs/pull/802
 
 
   

This is a PR merged from a forked repository.
As GitHub hides the original diff on merge, it is displayed below for
the sake of provenance:

As this is a foreign pull request (from a fork), the diff is supplied
below (as it won't show otherwise due to GitHub magic):

diff --git a/doc/installing-a-development-environment.md b/doc/installing-a-development-environment.md
index 48f8a3151..5020839fe 100644
--- a/doc/installing-a-development-environment.md
+++ b/doc/installing-a-development-environment.md
@@ -1,16 +1,34 @@
 ## Installing
 
-### Ruby
+### Mac OS X
 
-Ruby 2.0 is required to build the docs. NOTE: *The docs will not build with Ruby 1.8, 1.9
or 2.4.*
-
-#### Mac OS X
+#### Ruby
 
 Install Homebrew from [this site][homebrew], and then run:
 
     brew install ruby@2.0
 
-#### Windows
+#### Python
+
+Mac OS X comes with Python 2.7 pre-installed. Else, follow these steps:
+
+1. Download [this installer][python_installer_mac] from [this page][python_downloads].
+2. Run the downloaded file.
+
+#### Node.js
+
+Go to [this site][nodejs], and click the "Install" button. Then run the downloaded file and
follow the on-screen instructions. Make sure that the option to **install NPM** is enabled,
if you see one.
+
+#### Make (optional)
+
+Make comes with the Xcode Command Line Tools. To install them, run:
+
+    xcode-select --install
+
+
+### Windows
+
+#### Ruby
 
 Follow these steps:
 
@@ -31,57 +49,64 @@ Follow these steps:
             ruby dk.rb install
     1. Close `cmd.exe`.
 
-#### Linux
-
-Run the commands from [this site][ruby_linux] that apply to your Linux distribution.
+#### Python
 
-#### Verify Ruby
+Python 2.7 is also required to build the docs. NOTE: *The docs will not build with Python
3.0 or greater.*
 
-Verify your Ruby installation by running:
+Follow these steps:
 
-    ruby --version
+1. Download [this installer][python_installer_windows] from [this page][python_downloads].
+2. Run the downloaded file.
+   1. Use the default installation path
+   1. Make sure the **'add executable to path'** option is checked.
 
-### Python
+#### Node.js
 
-Python 2.7 is also required to build the docs. NOTE: *The docs will not build with Python
3.0 or greater.*
+Go to [this site][nodejs], and click the "Install" button. Then run the downloaded file and
follow the on-screen instructions. Make sure that the option to **install NPM** is enabled,
if you see one.
 
-#### Mac OS X
+#### Make (optional)
 
-Mac OS X comes with Python 2.7 pre-installed. Else, follow these steps:
+Make can be installed on Windows from [this page][make_page] by downloading the [setup tool][make_setup]
and running it.
 
-1. Download [this installer][python_installer_mac] from [this page][python_downloads].
-2. Run the downloaded file.
 
-#### Windows
+### Linux
 
-Follow these steps:
+#### Ruby
 
-1. Download [this installer][python_installer_windows] from [this page][python_downloads].
-2. Run the downloaded file.
-   1. Use the default installation path
-   1. Make sure the **'add executable to path'** option is checked.
+Run the commands from [this site][ruby_linux] that apply to your Linux distribution.
 
-#### Linux
+#### Python
 
 The latest version of CentOS, Fedora, Redhat Enterprise (RHEL) and Ubuntu come with Python
2.7 pre-installed. Else, follow the steps from [this site][python_linux].
 
-#### Verify Python
+#### Node.js
 
-Verify your Python installation by running:
+Follow the instructions on [this site][linux_node].
 
-    python --version
+#### Make
 
-The version must be 2.7.x.
+Make is installed by default on Linux.
 
-### Node.js
 
-#### Mac OS X &amp; Windows
+### Check Installations
 
-Go to [this site][nodejs], and click the "Install" button. Then run the downloaded file and
follow the on-screen instructions. Make sure that the option to **install NPM** is enabled,
if you see one.
+#### Verify Ruby
+
+Ruby 2.0 is required to build the docs. NOTE: *The docs will not build with Ruby 1.8, 1.9
or 2.4.* 
+
+Verify your Ruby installation by running:
+
+    ruby --version
+
+#### Verify Python
+
+Python 2.7 is also required to build the docs. NOTE: *The docs will not build with Python
3.0 or greater.*
 
-#### Linux
+Verify your Python installation by running:
 
-Linux, follow the instructions on [this site][linux_node].
+    python --version
+
+The version must be 2.7.x.
 
 #### Verify Node.js
 
@@ -90,6 +115,13 @@ Verify your Node.js installation by running:
     node --version
     npm --version
 
+#### Verify make
+
+Verify your make installation by running:
+
+    make --version
+
+
 ### Local repo setup
 
 Clone the [cordova-docs] GitHub repo to a local folder.
@@ -111,30 +143,6 @@ Finally, install Node.js and JavaScript dependencies by running:
 
     npm install
 
-### Make (optional)
-
-The website can be built with Gulp or Make. The Gulp workflow is enabled by just installing
all the JavaScript dependencies. The Make workflow usually allows for faster builds, but requires
installation of the `make` tool.
-
-#### Windows
-
-Make can be installed on Windows from [this page][make_page] by downloading the [setup tool][make_setup]
and running it.
-
-#### Mac OS X
-
-Make comes with the Xcode Command Line Tools. To install them, run:
-
-    xcode-select --install
-
-#### Linux
-
-Make is installed by default on Linux.
-
-#### Verify make
-
-Verify your make installation by running:
-
-    make --version
-
 
 ### Troubleshooting
 


 

----------------------------------------------------------------
This is an automated message from the Apache Git Service.
To respond to the message, please log on GitHub and use the
URL above to go to the specific comment.
 
For queries about this service, please contact Infrastructure at:
users@infra.apache.org


> Restructure and test "Installing" instructions
> ----------------------------------------------
>
>                 Key: CB-13400
>                 URL: https://issues.apache.org/jira/browse/CB-13400
>             Project: Apache Cordova
>          Issue Type: Sub-task
>          Components: cordova-docs
>            Reporter: Jan Piotrowski (Sujan)
>            Priority: Major
>
> When https://github.com/apache/cordova-docs/pull/745 is merged, the resulting "installing-a-development-environment.md"
should be a) tested for correctness and b) restructure by platform instead of by tech. Makes
much more sense, as one will only work through the list for one platform. c) might be to add
some explanation which tech is used for which reason and part of the site.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@cordova.apache.org
For additional commands, e-mail: issues-help@cordova.apache.org


Mime
View raw message