cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF subversion and git services (JIRA)" <>
Subject [jira] [Commented] (CB-13831) Update `android-versions` npm dependency to support Android API 27.
Date Fri, 26 Jan 2018 16:03:00 GMT


ASF subversion and git services commented on CB-13831:

Commit f91102ee0707b0d4528cda8967c14810c3b8e16e in cordova-android's branch refs/heads/master
from [~abernix]
[;h=f91102e ]

CB-13831: (android) Update `android-versions` to 1.3.0 to support SDK 27.

The `android-versions@1.3.0` version now has support for Android SDK level
27 thanks to

As the `android-versions` npm is a "bundled dependency" this will only
take effect when a new version of `cordova-android` is published, since
bundled dependencies are packed within the npm at publish time, not
automatically fetched as dependencies at publish time (which would have
normally been covered for new installations of cordova-android@7.0.0
thanks to semver caret notation).

> Update `android-versions` npm dependency to support Android API 27.
> -------------------------------------------------------------------
>                 Key: CB-13831
>                 URL:
>             Project: Apache Cordova
>          Issue Type: Task
>          Components: cordova-android
>            Reporter: Jesse Rosenberger
>            Assignee: Joe Bowser
>            Priority: Trivial
> The current version of {{cordova-android}} currently bundles (via {{package.json}}'s
{{bundledDependencies}} attribute) a version of the [{{android-versions}} npm|]
which doesn't support Android SDK level 27, which was officially released in the last month.
> This omission prevents the use of {{cordova run android --emulator -d}} if API level
27 is installed, which is the default SDK for a new installation of Android Studio.  It also
contributed to the error seen in CB-13571, though that will prevent the same error from occurring
in the future if an additional SDK is released and not included in {{android-versions}}.
> While the latest version of {{android-versions}} (currently 1.3.0) does support level
27 (now, thanks to [this recent commit|]), the
fact that it is a so-called "bundled dependency" means the current version (1.2.1) is baked
into the {{cordova-android}} installation tarball, and won't automatically respect the caret
version range (`^1.2.1`) listed in {{cordova-android}}`s {{package.json}}, despite the lack
of a {{package-lock.json}} (or otherwise).
> Bumping the version of {{android-versions}} in {{cordova-android}}'s {{package.json}}
to 1.3.0 will enable the emulator to work with API level 27 (even if there _could_ be other
reasons that API level 27 causes problems).

This message was sent by Atlassian JIRA

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message