cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CB-13831) Update `android-versions` npm dependency to support Android API 27.
Date Fri, 26 Jan 2018 16:03:00 GMT

    [ https://issues.apache.org/jira/browse/CB-13831?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16341197#comment-16341197
] 

ASF GitHub Bot commented on CB-13831:
-------------------------------------

infil00p commented on issue #430: CB-13831: (android) Update `android-versions` to 1.3.0 to
support SDK 27.
URL: https://github.com/apache/cordova-android/pull/430#issuecomment-360825543
 
 
   Neat!  This must have just happened, since I didn't see this published when I did the API
bump.

----------------------------------------------------------------
This is an automated message from the Apache Git Service.
To respond to the message, please log on GitHub and use the
URL above to go to the specific comment.
 
For queries about this service, please contact Infrastructure at:
users@infra.apache.org


> Update `android-versions` npm dependency to support Android API 27.
> -------------------------------------------------------------------
>
>                 Key: CB-13831
>                 URL: https://issues.apache.org/jira/browse/CB-13831
>             Project: Apache Cordova
>          Issue Type: Task
>          Components: cordova-android
>            Reporter: Jesse Rosenberger
>            Assignee: Joe Bowser
>            Priority: Trivial
>
> The current version of {{cordova-android}} currently bundles (via {{package.json}}'s
{{bundledDependencies}} attribute) a version of the [{{android-versions}} npm|https://npm.im/android-versions]
which doesn't support Android SDK level 27, which was officially released in the last month.
> This omission prevents the use of {{cordova run android --emulator -d}} if API level
27 is installed, which is the default SDK for a new installation of Android Studio.  It also
contributed to the error seen in CB-13571, though that will prevent the same error from occurring
in the future if an additional SDK is released and not included in {{android-versions}}.
> While the latest version of {{android-versions}} (currently 1.3.0) does support level
27 (now, thanks to [this recent commit|https://github.com/dvoiss/android-versions/commit/230957205eeb26e569096251a32179e88a28acfc]), the
fact that it is a so-called "bundled dependency" means the current version (1.2.1) is baked
into the {{cordova-android}} installation tarball, and won't automatically respect the caret
version range (`^1.2.1`) listed in {{cordova-android}}`s {{package.json}}, despite the lack
of a {{package-lock.json}} (or otherwise).
> Bumping the version of {{android-versions}} in {{cordova-android}}'s {{package.json}}
to 1.3.0 will enable the emulator to work with API level 27 (even if there _could_ be other
reasons that API level 27 causes problems).



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@cordova.apache.org
For additional commands, e-mail: issues-help@cordova.apache.org


Mime
View raw message