cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <>
Subject [jira] [Commented] (CB-13831) Update `android-versions` npm dependency to support Android API 27.
Date Thu, 25 Jan 2018 18:46:00 GMT


ASF GitHub Bot commented on CB-13831:

codecov-io commented on issue #430: CB-13831: (android) Update `android-versions` to 1.3.0
to support SDK 27.
   # [Codecov]( Report
   > Merging [#430](
into [master](
will **not change** coverage.
   > The diff coverage is `n/a`.
   [![Impacted file tree graph](](
   @@           Coverage Diff           @@
   ##           master     #430   +/-   ##
     Coverage   43.95%   43.95%           
     Files          17       17           
     Lines        1711     1711           
     Branches      318      318           
     Hits          752      752           
     Misses        959      959
   [Continue to review full report at Codecov](
   > **Legend** - [Click here to learn more](
   > `Δ = absolute <relative> (impact)`, `ø = not affected`, `? = missing data`
   > Powered by [Codecov](
Last update [cc08e9d...f91102e](
Read the [comment docs](

This is an automated message from the Apache Git Service.
To respond to the message, please log on GitHub and use the
URL above to go to the specific comment.
For queries about this service, please contact Infrastructure at:

> Update `android-versions` npm dependency to support Android API 27.
> -------------------------------------------------------------------
>                 Key: CB-13831
>                 URL:
>             Project: Apache Cordova
>          Issue Type: Task
>          Components: cordova-android
>            Reporter: Jesse Rosenberger
>            Assignee: Joe Bowser
>            Priority: Trivial
> The current version of {{cordova-android}} currently bundles (via {{package.json}}'s
{{bundledDependencies}} attribute) a version of the [{{android-versions}} npm|]
which doesn't support Android SDK level 27, which was officially released in the last month.
> This omission prevents the use of {{cordova run android --emulator -d}} if API level
27 is installed, which is the default SDK for a new installation of Android Studio.  It also
contributed to the error seen in CB-13571, though that will prevent the same error from occurring
in the future if an additional SDK is released and not included in {{android-versions}}.
> While the latest version of {{android-versions}} (currently 1.3.0) does support level
27 (now, thanks to [this recent commit|]), the
fact that it is a so-called "bundled dependency" means the current version (1.2.1) is baked
into the {{cordova-android}} installation tarball, and won't automatically respect the caret
version range (`^1.2.1`) listed in {{cordova-android}}`s {{package.json}}, despite the lack
of a {{package-lock.json}} (or otherwise).
> Bumping the version of {{android-versions}} in {{cordova-android}}'s {{package.json}}
to 1.3.0 will enable the emulator to work with API level 27 (even if there _could_ be other
reasons that API level 27 causes problems).

This message was sent by Atlassian JIRA

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message