cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jesse Rosenberger (JIRA)" <>
Subject [jira] [Updated] (CB-13831) Update `android-versions` npm dependency to support Android API 27.
Date Thu, 25 Jan 2018 17:49:00 GMT


Jesse Rosenberger updated CB-13831:
    Issue Type: Task  (was: New Feature)

> Update `android-versions` npm dependency to support Android API 27.
> -------------------------------------------------------------------
>                 Key: CB-13831
>                 URL:
>             Project: Apache Cordova
>          Issue Type: Task
>          Components: cordova-android
>            Reporter: Jesse Rosenberger
>            Assignee: Joe Bowser
>            Priority: Trivial
> The current version of {{cordova-android}} currently bundles (via {{package.json}}'s
{{bundledDependencies}} attribute) a version of the [{{android-versions}} npm|]
which doesn't support Android SDK level 27, which was officially released in the last month.
> While the latest version of {{android-versions}} (currently 1.3.0) does support level
27 (now, thanks to [this recent commit|]), the
fact that it is a so-called "bundled dependency" means the current version (1.2.1) is baked
into the {{cordova-android}} installation tarball, and won't automatically respect the caret
version range (`^1.2.1`) listed in {{cordova-android}}`s {{package.json}}, despite the lack
of a {{package-lock.json}} (or otherwise).
> Bumping the version of {{android-versions}} in {{cordova-android}}'s {{package.json}}
to 1.3.0 will enable API level 27 to be used.

This message was sent by Atlassian JIRA

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message