cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "jcesarmobile (JIRA)" <>
Subject [jira] [Commented] (CB-13780) Should allow preferences having empty default
Date Mon, 15 Jan 2018 12:47:00 GMT


jcesarmobile commented on CB-13780:

As user you can set the preference with an empty value in the config.xml

As plugin developer, if you want to use latest then just don't use a variable and provide
and empty spec.
I don't think it's good to allow users to decide which spec to use as the plugin code might
not work with all versions.


Anyway, keeping it open, emtpy default might be good for some other use cases

> Should allow preferences having empty default
> ---------------------------------------------
>                 Key: CB-13780
>                 URL:
>             Project: Apache Cordova
>          Issue Type: Improvement
>          Components: cordova-lib
>            Reporter: Adriano Di Giovanni
>            Priority: Trivial
>              Labels: framework, plugin, podspec
> Please,
> consider the following snippet from plugin.xml
> {code:java}
> <platform name="ios"><preference name="VERSION" default="" /><framework
src="Google-Mobile-Ads-SDK" type="podspec" spec="$VERSION" /></platform>
> {code}
> It would be useful if preferences having an empty default are considered valid instead
of missing.
> This new behavior lets you use a preference to specify a podspec version and if the
preference has empty default, it means the latest version should be installed.
> Today, there is no other way to do it unless CocoaPods changes podfile to let you specify
something like +, * or latest to install the latest version of a podspec (instead of omitting
the version at all).

This message was sent by Atlassian JIRA

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message