cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alexander Tchitchigin (JIRA)" <>
Subject [jira] [Commented] (CB-13739) Android build is broken due to libraries with text relocations
Date Tue, 16 Jan 2018 12:17:00 GMT


Alexander Tchitchigin commented on CB-13739:

I've just tried downgrading to every version down to cordova@6.4.0 - no luck. I get the same
errors with relocations. I strongly suspect it's some problem with Android SDK. Is there any
guide on proper Android SDK installation? I still use and update pretty old SDK version, maybe
that's the problem?

> Android build is broken due to libraries with text relocations
> --------------------------------------------------------------
>                 Key: CB-13739
>                 URL:
>             Project: Apache Cordova
>          Issue Type: Bug
>          Components: cordova-android
>    Affects Versions: cordova-android-7.0.0
>         Environment: Build systems: Ubuntu Linux and PhoneGap Build
> Android versions: 5.0.2 and 7.1.2
>            Reporter: Alexander Tchitchigin
>            Assignee: Joe Bowser
>            Priority: Major
>         Attachments: photo_2018-01-08_12-25-17.jpg
> When I build an Android app and run it on a device I get the result in the screenshot:
there are a number of libraries with text relocations that Android refuses to load hence the
application is broken and doesn't work. Release build refuses to start at all.
> Before updating Cordova and Android SDK everything worked OK, I was able to build and
run the app and previous version is published to Google Play. But I didn't memorize the version
number when it all worked, unfortunately. App code was updated either but I don't see how
updated JS, CSS and images could make Cordova link with new libraries with relocations.
> Cordova behaves the same to me both locally with the latest version (cordova 8.0.0, android
7.0.0) and in PhoneGap Build.
> I'd like to know the right build settings to produce working build or at least some workaround.
I tried to play with cdvBuildToolsVersion and cdvCompileSdkVersion but had no success.

This message was sent by Atlassian JIRA

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message