cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Joe Bowser (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (CB-13646) Unable to compile native code (android.useDeprecated.Ndk not supported anymore)
Date Mon, 18 Dec 2017 22:30:00 GMT

     [ https://issues.apache.org/jira/browse/CB-13646?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Joe Bowser updated CB-13646:
----------------------------
    Labels: cordova-next  (was: )

> Unable to compile native code (android.useDeprecated.Ndk not supported anymore)
> -------------------------------------------------------------------------------
>
>                 Key: CB-13646
>                 URL: https://issues.apache.org/jira/browse/CB-13646
>             Project: Apache Cordova
>          Issue Type: Bug
>          Components: cordova-android
>    Affects Versions: 7.0.0
>            Reporter: Michael Goffioul
>            Assignee: Joe Bowser
>            Priority: Critical
>              Labels: cordova-next
>
> A cordova project that contains native/jni code fails to compile, because android.useDeprecatedNdk
is not supported anymore.
> Steps to reproduce:
> 1) create a new cordova project
> 2) add android platform
> 3) mkdir platforms/android/app/src/main/jni
> 4) touch platforms/android/app/src/main/jni/Android.mk
> 5) cordova build android
> It fails with the following error:
> {code}
> FAILURE: Build failed with an exception.
> * What went wrong:
> Execution failed for task ':app:compileDebugNdk'.
> > Error: Flag android.useDeprecatedNdk is no longer supported and will be removed
in the next version of Android Studio.  Please switch to a supported build system.
>   Consider using CMake or ndk-build integration. For more information, go to:
>    https://d.android.com/r/studio-ui/add-native-code.html#ndkCompile
>    To get started, you can use the sample ndk-build script the Android
>    plugin generated for you at: .../testnative/platforms/android/app/build/intermediates/ndk/debug/Android.mk
>   Alternatively, you can use the experimental plugin:
>    https://developer.android.com/r/tools/experimental-plugin.html
>   To continue using the deprecated NDK compile for another 60 days, set 
>   android.deprecatedNdkCompileLease=1512654767567 in gradle.properties
> {code}



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@cordova.apache.org
For additional commands, e-mail: issues-help@cordova.apache.org


Mime
View raw message