cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Colin Bau (JIRA)" <>
Subject [jira] [Comment Edited] (CB-13595) cordova build ios --device --release not work
Date Wed, 22 Nov 2017 02:28:00 GMT


Colin Bau edited comment on CB-13595 at 11/22/17 2:27 AM:

hi [~surajpindoria]
thanks your reply 
if you fix your provisioning profiles later,please help me to try and build again to see
if fix...
because I really check many times with my  provisioning profiles,really no problem at all
maybe build.json have some problem,if you have free time,please help me to check it
[click me to download my project|]

let me explain why it show /Volumes/ directory
My Mac OS is a VM System
I am not a Mac OS user but only a Windows user,I am just use Mac OS to build iOS application
my project "framework7" is in my PC's => D:\software\Cordova\framework7
I launch my VM,login to my "framework7" project,enter my PC's password
finally drag the "framework7" folder to the Mac OS commandline

above workflow that I am sure is OK
because I am not the first time to upload ipa to app store

detail screenshot all under here

was (Author: bau720123):
hi [~surajpindoria]
thanks your reply 
but [~Sujan12] said︰If you get the same error without `--release` it means this has nothing
to do with profiles and certificates - much simpler to debug.

who's explanation is correct ? it really A little confusion @_@

could I request [~surajpindoria] and [~Sujan12]
just use my sample project (a default ios@4.5.3 project)
[click me to download|]
or create your own ios@4.5.3 project

use your own Provisioning Profiles or certificates or build.json file to build the project
to success ?
no matter which way...
cordova build ios --device => (*{color:red}+for now we are tryng for this+{color}*)
cordova build ios --device --release

by the way [~surajpindoria]
if I manually use Xcode to build,it will build success and generate a ipa file finally

> cordova build ios --device --release not work
> ---------------------------------------------
>                 Key: CB-13595
>                 URL:
>             Project: Apache Cordova
>          Issue Type: Bug
>          Components: cordova-ios
>    Affects Versions: cordova-ios 4.5.0
>         Environment: cordova -v︰7.1.0
> node -v︰8.9.1
> Xcode 9.1(9B55)
> cordova ios︰4.5.3
> macOS High Sierra 10.13
>            Reporter: Colin Bau
>            Assignee: Suraj Pindoria
>              Labels: ios
> step 1
> I import my Provisioning Profiles to keychain (double click)
> !!
> !!
> step 2
> I prepare the build.json file (I tried the older format and new format but still no luck)
> I am very sure the "provisionProfile" is correct (it was my provisionProfile's UUID)
> [link title|]
> !!
> !!
> step 3
> I use Xcode and setting the Signing,it will build success
> !!
> !!
> step 4
> but if I use︰cordova build ios --device --release
> it will  "ARCHIVED FAIL"
> !!
> !!
> !!
> in previous cordova-ios version,above workflow is work perfect and it will generate
a ipa format file finally
> but in new cordova-ios or Xcode version,it seem not work anymore
> if I miss something or give me some hint to solve it ?

This message was sent by Atlassian JIRA

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message