cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Frédéric Camblor (JIRA) <j...@apache.org>
Subject [jira] [Updated] (CB-13433) cordova.js not being packaging during cordova build --release
Date Thu, 12 Oct 2017 08:13:01 GMT

     [ https://issues.apache.org/jira/browse/CB-13433?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Frédéric Camblor updated CB-13433:
----------------------------------
    Description: 
I'm building an ios & android application for some time now (~2 years) and I don't understand
why, on my latest release, my production (\-\-device \-\-release) build doesn't embed cordova.js
file anymore where as non-production build (--debug) does.
I can confirm this with an alert(window.cordova) which shows "undefined" at startup and after
a ~30s delay (to make sure cordova is not bootstrapped after a deviceReady is fired)

It sounds like a bug on my side, however I can't really know how to confirm that as I don't
have a lot of knowledge on cordova building process internals.

What I can tell so far :
- cordova.js is currently not packaged on both android and ios as soon as I `cordova build
--device --release ios|android`
- cordova.js is currently packaged on both android and ios as soon as I `cordova build --debug
ios|android`
- In my latest release, 2 monthes ago (August 17th), `cordova build --device --release ios|android`
was working perfectly fine. 
  Noticeable changes since then were :
-- package.json : I removed ios-deploy@1.9.0 dependency & added xml2js@0.4.19
-- config.xml : I upgraded cordova-plugin-splashscreen@~3.2.2 => cordova-plugin-splashscreen@4.0.3
& cordova-ios@4.1.1 => cordova-ios@https://github.com/apache/cordova-ios#4.5.2 &
added 2 new plugins (cordova-plugin-request-location-accuracy and cordova-android-support-gradle-release)
-- my build process (grunt-based) didn't changed for 6 monthes
-- I made a change un July, so "integrated" into my latest *working* release which was to
include cordova.js file inside my main index.html page in the end of the <head> tag,
and before any other js script (my other js scripts are loaded in the end of the <body>
tag)

When I look for cordova.js file in platforms/ directory, it show me :
{code}
> find platforms -name cordova.js
platforms/android/assets/www/cordova.js
platforms/android/build/intermediates/assets/debug/www/cordova.js
platforms/android/build/intermediates/assets/release/www/cordova.js
platforms/android/platform_www/cordova.js
platforms/browser/platform_www/cordova.js
platforms/ios/<MY APP NAME>.xcarchive/Products/Applications/<MY APP NAME>.app/www/cordova.js
platforms/ios/CordovaLib/cordova.js
platforms/ios/platform_www/cordova.js
platforms/ios/www/cordova.js
{code}

If someone has any hint for debugging this, it would be very kind.

  was:
I'm building an ios & android application for some time now (~2 years) and I don't understand
why, on my latest release, my production (--device --release) build doesn't embed cordova.js
file anymore where as non-production build (--debug) does.
I can confirm this with an alert(window.cordova) which shows "undefined" at startup and after
a ~30s delay (to make sure cordova is not bootstrapped after a deviceReady is fired)

It sounds like a bug on my side, however I can't really know how to confirm that as I don't
have a lot of knowledge on cordova building process internals.

What I can tell so far :
- cordova.js is currently not packaged on both android and ios as soon as I `cordova build
--device --release ios|android`
- cordova.js is currently packaged on both android and ios as soon as I `cordova build --debug
ios|android`
- In my latest release, 2 monthes ago (August 17th), `cordova build --device --release ios|android`
was working perfectly fine. Noticeable changes since then were :
-- package.json : I removed ios-deploy@1.9.0 dependency & added xml2js@0.4.19
-- config.xml : I upgraded cordova-plugin-splashscreen@~3.2.2 => cordova-plugin-splashscreen@4.0.3
& cordova-ios@4.1.1 => cordova-ios@https://github.com/apache/cordova-ios#4.5.2 &
added 2 new plugins (cordova-plugin-request-location-accuracy and cordova-android-support-gradle-release)
-- my build process (grunt-based) didn't changed for 6 monthes
-- I made a change un July, so "integrated" into my latest *working* release which was to
include cordova.js file inside my main index.html page in the end of the <head> tag,
and before any other js script (my other js scripts are loaded in the end of the <body>
tag)

When I look for cordova.js file in platforms/ directory, it show me :
{code}
> find platforms -name cordova.js
platforms/android/assets/www/cordova.js
platforms/android/build/intermediates/assets/debug/www/cordova.js
platforms/android/build/intermediates/assets/release/www/cordova.js
platforms/android/platform_www/cordova.js
platforms/browser/platform_www/cordova.js
platforms/ios/<MY APP NAME>.xcarchive/Products/Applications/<MY APP NAME>.app/www/cordova.js
platforms/ios/CordovaLib/cordova.js
platforms/ios/platform_www/cordova.js
platforms/ios/www/cordova.js
{code}

If someone has any hint for debugging this, it would be very kind.


> cordova.js not being packaging during cordova build --release
> -------------------------------------------------------------
>
>                 Key: CB-13433
>                 URL: https://issues.apache.org/jira/browse/CB-13433
>             Project: Apache Cordova
>          Issue Type: Bug
>          Components: cordova-cli
>    Affects Versions: 6.5.0
>         Environment: cordova-cli 6.5.0
> cordova-android 6.2.3
> cordova-ios 4.5.2 (using https://github.com/apache/cordova-ios#4.5.2 as cordova-ios@4.5.2
is not publicly available in npm yet) .. anyway, I don't think this is relevant as I have
the same issue on android builds
>            Reporter: Frédéric Camblor
>              Labels: android, ios
>
> I'm building an ios & android application for some time now (~2 years) and I don't
understand why, on my latest release, my production (\-\-device \-\-release) build doesn't
embed cordova.js file anymore where as non-production build (--debug) does.
> I can confirm this with an alert(window.cordova) which shows "undefined" at startup and
after a ~30s delay (to make sure cordova is not bootstrapped after a deviceReady is fired)
> It sounds like a bug on my side, however I can't really know how to confirm that as I
don't have a lot of knowledge on cordova building process internals.
> What I can tell so far :
> - cordova.js is currently not packaged on both android and ios as soon as I `cordova
build --device --release ios|android`
> - cordova.js is currently packaged on both android and ios as soon as I `cordova build
--debug ios|android`
> - In my latest release, 2 monthes ago (August 17th), `cordova build --device --release
ios|android` was working perfectly fine. 
>   Noticeable changes since then were :
> -- package.json : I removed ios-deploy@1.9.0 dependency & added xml2js@0.4.19
> -- config.xml : I upgraded cordova-plugin-splashscreen@~3.2.2 => cordova-plugin-splashscreen@4.0.3
& cordova-ios@4.1.1 => cordova-ios@https://github.com/apache/cordova-ios#4.5.2 &
added 2 new plugins (cordova-plugin-request-location-accuracy and cordova-android-support-gradle-release)
> -- my build process (grunt-based) didn't changed for 6 monthes
> -- I made a change un July, so "integrated" into my latest *working* release which was
to include cordova.js file inside my main index.html page in the end of the <head> tag,
and before any other js script (my other js scripts are loaded in the end of the <body>
tag)
> When I look for cordova.js file in platforms/ directory, it show me :
> {code}
> > find platforms -name cordova.js
> platforms/android/assets/www/cordova.js
> platforms/android/build/intermediates/assets/debug/www/cordova.js
> platforms/android/build/intermediates/assets/release/www/cordova.js
> platforms/android/platform_www/cordova.js
> platforms/browser/platform_www/cordova.js
> platforms/ios/<MY APP NAME>.xcarchive/Products/Applications/<MY APP NAME>.app/www/cordova.js
> platforms/ios/CordovaLib/cordova.js
> platforms/ios/platform_www/cordova.js
> platforms/ios/www/cordova.js
> {code}
> If someone has any hint for debugging this, it would be very kind.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@cordova.apache.org
For additional commands, e-mail: issues-help@cordova.apache.org


Mime
View raw message