cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CB-13289) Gradle/Android Plugin DSL change breaks including CordovaLib
Date Thu, 26 Oct 2017 14:50:00 GMT

    [ https://issues.apache.org/jira/browse/CB-13289?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16220562#comment-16220562
] 

ASF GitHub Bot commented on CB-13289:
-------------------------------------

filmaj commented on issue #413: CB-13289: This fixes the Cordova-Android build on cordova-android
6.x
URL: https://github.com/apache/cordova-android/pull/413#issuecomment-339691310
 
 
   Hmm, should we tweak the `.travis.yml` and `appveyor.yml` files to also install the 26.0.2
build tools, then? Currently we tell both [Travis](https://github.com/apache/cordova-android/blob/master/.travis.yml#L17)
and [Appveyor](https://github.com/apache/cordova-android/blob/master/appveyor.yml#L20) to
install `build-tools-26.0.0`.
   
   

----------------------------------------------------------------
This is an automated message from the Apache Git Service.
To respond to the message, please log on GitHub and use the
URL above to go to the specific comment.
 
For queries about this service, please contact Infrastructure at:
users@infra.apache.org


> Gradle/Android Plugin DSL change breaks including CordovaLib
> ------------------------------------------------------------
>
>                 Key: CB-13289
>                 URL: https://issues.apache.org/jira/browse/CB-13289
>             Project: Apache Cordova
>          Issue Type: Bug
>          Components: cordova-android
>    Affects Versions: 6.2.1
>            Reporter: Joe Bowser
>            Assignee: Joe Bowser
>            Priority: Blocker
>              Labels: android-next
>             Fix For: 7.0.0
>
>
> Android Studio 3.0.0 uses a new DSL, and this breaks the dependency list.  This directly
affects Cordova plugins that work as a Library Module, as well as adding and removing the
Android platform.  Basically, once Android Studio 3.0 updates, Cordova projects will not work
properly with the new version of Android Studio once they're updated.
> This depends on CB-11244



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@cordova.apache.org
For additional commands, e-mail: issues-help@cordova.apache.org


Mime
View raw message