cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "sandstrom (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CB-13050) globalization plugin modernization / polyfill to latest spec
Date Mon, 25 Sep 2017 12:56:01 GMT

    [ https://issues.apache.org/jira/browse/CB-13050?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16178991#comment-16178991
] 

sandstrom commented on CB-13050:
--------------------------------

Although I think it's a bad idea to make the alignment listed above (my reasoning here: https://issues.apache.org/jira/browse/CB-12723),
if you do need a polyfill this one is pretty good: https://github.com/andyearnshaw/Intl.js

> globalization plugin modernization / polyfill to latest spec
> ------------------------------------------------------------
>
>                 Key: CB-13050
>                 URL: https://issues.apache.org/jira/browse/CB-13050
>             Project: Apache Cordova
>          Issue Type: Task
>          Components: cordova-plugin-globalization
>            Reporter: Filip Maj
>              Labels: plugins-next
>
> Per CB-12723, we will keep this plugin around but try to align with latest specs:
>  - https://developer.mozilla.org/en/docs/Web/JavaScript/Reference/Global_Objects/Intl

>  - https://tc39.github.io/ecma402/#intl-object.
>  - https://marcoscaceres.github.io/jsi18n/
> Apparently would just need polyfilling on iOS 9 and below. Need to test that.
> Platform support documentation should be updated to reflect polyfill status, if applicable.




--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@cordova.apache.org
For additional commands, e-mail: issues-help@cordova.apache.org


Mime
View raw message