cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Joe Bowser (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CB-12906) Embed Youtube iFrames - fullscreen no video on Android.
Date Fri, 16 Jun 2017 16:16:01 GMT

    [ https://issues.apache.org/jira/browse/CB-12906?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16052082#comment-16052082
] 

Joe Bowser commented on CB-12906:
---------------------------------

This sounds like a WebView playback bug on the WebView.  It's possible that Chrome has some
handler to manage that, but Full Screen video has been known to be fairly buggy on Cordova,
namely with the back button state breaking, so it's probably better to hand it off to the
YouTube app to play if you need full screen.

> Embed Youtube iFrames - fullscreen no video on Android.
> -------------------------------------------------------
>
>                 Key: CB-12906
>                 URL: https://issues.apache.org/jira/browse/CB-12906
>             Project: Apache Cordova
>          Issue Type: Bug
>          Components: cordova-android
>    Affects Versions: cordova@7.0.0
>         Environment: Cordova Android 6.2.3
> Android 7
>            Reporter: Shawn Lan
>
> This is a weird issue. Running on Cordova Android, if I have a iFrame embed Youtube video
with width and height set to 100%:
>     <iframe width="100%" height="100%" src="https://www.youtube.com/embed/2Xk744838J4"
frameborder="0" allowfullscreen></iframe>
> When switching to fullscreen using the native control, the screen becomes black. No video,
but audio keeps playing. Rotating the screen doesn't help.
> If I set a fixed width and height:
>     <iframe width="560" height="315" src="https://www.youtube.com/embed/2Xk744838J4"
frameborder="0" allowfullscreen></iframe>
> When switching to fullscreen, at first the screen is still black. Once I rotate the screen,
the video shows. Better than the first scenario.
> Sometimes it just work for both scenarios, but most of the time, it has issues as described
above.
> I'm running on Android 7.0, Samsung S7. Is it just my device, or some kind of bug?



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@cordova.apache.org
For additional commands, e-mail: issues-help@cordova.apache.org


Mime
View raw message