cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CB-12856) Skip CocoaPods check_reqs if on non-darwin (macOS) platform
Date Fri, 26 May 2017 23:55:05 GMT

    [ https://issues.apache.org/jira/browse/CB-12856?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16027038#comment-16027038
] 

ASF GitHub Bot commented on CB-12856:
-------------------------------------

Github user shazron commented on the issue:

    https://github.com/apache/cordova-ios/pull/313
  
    Array.includes failure on node 4 when on Windows. I will have to re-test everything again
-- this means also that the check_reqs is not covered in the unit-tests (which do test on
nodes 4 and 6), unit-tests are missing. 


> Skip CocoaPods check_reqs if on non-darwin (macOS) platform
> -----------------------------------------------------------
>
>                 Key: CB-12856
>                 URL: https://issues.apache.org/jira/browse/CB-12856
>             Project: Apache Cordova
>          Issue Type: Improvement
>          Components: cordova-ios
>            Reporter: Shazron Abdullah
>            Assignee: Shazron Abdullah
>             Fix For: cordova-ios@4.4.1
>
>
> For example, phonegap-plugin-push can be installed on Windows, but if you have the cordova-ios
platform installed as well on Windows, it will fail the check_reqs CocoaPods check.
> Make the check_reqs CocoaPods check only fail with the additional requirement that the
platform is darwin (macOS). So if CocoaPods check fails, and the platform is non-darwin (Windows,
Linux), check_reqs passes.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@cordova.apache.org
For additional commands, e-mail: issues-help@cordova.apache.org


Mime
View raw message