cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jan Piotrowski (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (CB-12818) Improve `cordova requirements` to better help with debugging gradle + Android foo
Date Thu, 18 May 2017 16:27:04 GMT

    [ https://issues.apache.org/jira/browse/CB-12818?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16016032#comment-16016032
] 

Jan Piotrowski edited comment on CB-12818 at 5/18/17 4:26 PM:
--------------------------------------------------------------

One thing that would help is a check of the gradle version, instead of only checking if gradle
is installed.

[Here|https://forum.ionicframework.com/t/task-wrapper-not-found-in-root-project-android/88882]
a user got {{Error: /usr/share/gradle/bin/gradle: Command failed with exit code 1}}. Running
{{cordova requirements}} gave him this:

{code}
Requirements check results for android:
Java JDK: installed 1.8.0
Android SDK: installed true
Android target: installed android-25
Gradle: installed /usr/share/gradle/bin/gradle
{code}

Turns out his Gradle was v1.4, officially distributed for Ubuntu 14.04.
Upgrading to Gradle to v3.5 solved his problem.


was (Author: sujan12):
One thing that would help is a check of the gradle version, instead of only checking if gradle
is installed.

[Here|https://forum.ionicframework.com/t/task-wrapper-not-found-in-root-project-android/88882]
a user got {{Error: /usr/share/gradle/bin/gradle: Command failed with exit code 1}}. Running
{{cordova requirements}} gave him this:

{code}
Requirements check results for android:
Java JDK: installed 1.8.0
Android SDK: installed true
Android target: installed android-25
Gradle: installed /usr/share/gradle/bin/gradle
{code}

Turns out his Gradle was v1.4 one, officially distributed for Ubuntu 14.04.
Upgrading to Gradle to v3.5 solved his problem.

> Improve `cordova requirements` to better help with debugging gradle + Android foo
> ---------------------------------------------------------------------------------
>
>                 Key: CB-12818
>                 URL: https://issues.apache.org/jira/browse/CB-12818
>             Project: Apache Cordova
>          Issue Type: Improvement
>          Components: cordova-cli
>            Reporter: Jan Piotrowski
>            Assignee: Filip Maj
>            Priority: Minor
>
> `cordova requirements` could be more helpful to help debug problems with gradle and Android
stuff in general: Show the version and path where it found stuff or didn't find stuff, more
notes on PATH variables to set etc.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@cordova.apache.org
For additional commands, e-mail: issues-help@cordova.apache.org


Mime
View raw message