cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Shazron Abdullah (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CB-12749) coho should not care about license dependencies for "check-license"
Date Tue, 02 May 2017 01:00:20 GMT

    [ https://issues.apache.org/jira/browse/CB-12749?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15991920#comment-15991920
] 

Shazron Abdullah commented on CB-12749:
---------------------------------------

It may be my CWD, or some weird thing going on. I used `--no-chdir` and the warnings are there
but the command ran. I'll have to start fresh to see if its an actual bug.

> coho should not care about license dependencies for "check-license"
> -------------------------------------------------------------------
>
>                 Key: CB-12749
>                 URL: https://issues.apache.org/jira/browse/CB-12749
>             Project: Apache Cordova
>          Issue Type: Bug
>          Components: Coho
>            Reporter: Shazron Abdullah
>            Assignee: Shazron Abdullah
>
> We only care about licenses of code we ship (only code in the repo, like bundled deps).
> I did a fresh repo clone of the tools, for example. {{coho repo-clone -r tools}}
> Right now it complains about node_module deps:
> {code}
> coho check-license -r tools > license.txt
> Warning: dependency "configstore" probably not installed.
> please install dependencies from npm before running nlf
> Warning: dependency "cordova-common" probably not installed.
> please install dependencies from npm before running nlf
> Warning: dependency "cordova-lib" probably not installed.
> please install dependencies from npm before running nlf
> Warning: dependency "editor" probably not installed.
> please install dependencies from npm before running nlf
> Warning: dependency "insight" probably not installed.
> please install dependencies from npm before running nlf
> Warning: dependency "nopt" probably not installed.
> please install dependencies from npm before running nlf
> Warning: dependency "q" probably not installed.
> please install dependencies from npm before running nlf
> Warning: dependency "update-notifier" probably not installed.
> please install dependencies from npm before running nlf
> Warning: dependency "cordova-lib" probably not installed.
> please install dependencies from npm before running nlf
> Warning: dependency "nopt" probably not installed.
> please install dependencies from npm before running nlf
> Warning: dependency "q" probably not installed.
> please install dependencies from npm before running nlf
> Warning: dependency "cordova-app-hello-world" probably not installed.
> please install dependencies from npm before running nlf
> Warning: dependency "cordova-common" probably not installed.
> please install dependencies from npm before running nlf
> Warning: dependency "cordova-fetch" probably not installed.
> please install dependencies from npm before running nlf
> Warning: dependency "q" probably not installed.
> please install dependencies from npm before running nlf
> Warning: dependency "shelljs" probably not installed.
> please install dependencies from npm before running nlf
> Warning: dependency "valid-identifier" probably not installed.
> please install dependencies from npm before running nlf
> Warning: dependency "browserify" probably not installed.
> please install dependencies from npm before running nlf
> {code}



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@cordova.apache.org
For additional commands, e-mail: issues-help@cordova.apache.org


Mime
View raw message