cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "huang (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (CB-12615) cordova check_reqs.js cause build android fail
Date Thu, 06 Apr 2017 09:47:41 GMT

    [ https://issues.apache.org/jira/browse/CB-12615?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15956238#comment-15956238
] 

huang edited comment on CB-12615 at 4/6/17 9:47 AM:
----------------------------------------------------

Hi Audrey:

When I run cordova command " cordova requirements " or "cordova build android" ,Cordova
command tip: ' Android target: not installed '。
But,In my OS Environmental(Win 10 X64),Android SDK all version and all target and all
tools installed。
I following cordova  JS code,Find " platforms/android/cordova/lib/check_reqs.js " 249 line
,Code:'android list targets --compact' is Error,In Android SDK Command ,This is " android
list target --compact " , Not "targets",Is "target"。
My English is bad,Do you know what i mean ?


was (Author: xox9001):
Hi Audrey:

When I run cordova command " cordova requirements " or "cordova build android" ,Cordova
command tip: ' Android target: not installed '。
But,In my OS Environmental(Win 10 X64),Android SDK all version and all target and all
tools installed。
I following code,Find " platforms/android/cordova/lib/check_reqs.js " 249 line ,Code:'android
list targets --compact' is Error,In Android Command ,This command is " android list target
--compact " , Not "targets",Is "target"。
My English is bad,Do you know what i mean ?

> cordova check_reqs.js cause build android fail
> ----------------------------------------------
>
>                 Key: CB-12615
>                 URL: https://issues.apache.org/jira/browse/CB-12615
>             Project: Apache Cordova
>          Issue Type: Bug
>          Components: CLI
>    Affects Versions: 6.5.0
>         Environment: Windows 10
>            Reporter: huang
>
> this bug will cause cordova unable to find target enviroment because of the command error
that conflicts with stock android platform.
> stock android command is 
> 'cordova requirements check Android target '
> while the current command is
> return tryCommand('android list targets --compact', msg)
> apparently there is an extra 's' at the back of target.
> I use cordova create project ,add android platform, in platforms\android\cordova\lib\check_reqs.js
249 line, tryCommand('android list targets --compact', msg) ERROR
> in Android.bat ,This Command is "android list target --compact "



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@cordova.apache.org
For additional commands, e-mail: issues-help@cordova.apache.org


Mime
View raw message