cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dave Murray-Rust (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CB-12448) Can't use plugins when running on OSX
Date Wed, 12 Apr 2017 08:47:41 GMT

    [ https://issues.apache.org/jira/browse/CB-12448?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15965566#comment-15965566
] 

Dave Murray-Rust commented on CB-12448:
---------------------------------------

p.s. I can confirm that the config.xml gets changed to remove the plugin's feature tag. Unfortunately,
adding it back to the file doesn't seem to work.

> Can't use plugins when running on OSX
> -------------------------------------
>
>                 Key: CB-12448
>                 URL: https://issues.apache.org/jira/browse/CB-12448
>             Project: Apache Cordova
>          Issue Type: Bug
>          Components: AllPlugins, OSX
>    Affects Versions: 4.0.1
>         Environment: OSX 10.10.5
>            Reporter: Dave Murray-Rust
>            Assignee: Kerri Shotts
>            Priority: Blocker
>
> I can't use any plugins so far when I deploy on OSX. I have tried cordova-plugin-file,
cordova-plugin-camera and cordova-plugin-bluetoothle.
> In each case, it works fine on Android, but fails on OSX with a message like "10/02/2017
15:03:28.056 HelloWorld[15580]: ERROR: Plugin 'File' not found, or is not a CDVPlugin. Check
your plugin mapping in config.xml."
> I'm using the command line. I have tried removing all the platforms and adding them again.
I am running with "cordova run osx".
> I'm not sure what version of cordova I have - I installed using 'npm install -g cordova'.
'cordova version' reports 6.5.0, but that version does not seem to exist in the dropdown above.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@cordova.apache.org
For additional commands, e-mail: issues-help@cordova.apache.org


Mime
View raw message