cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kerri Shotts (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CB-12548) Redirection not happening with InAppBrowser when using with Yammer JS sdk for authentication
Date Wed, 08 Mar 2017 16:50:38 GMT

    [ https://issues.apache.org/jira/browse/CB-12548?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15901536#comment-15901536
] 

Kerri Shotts commented on CB-12548:
-----------------------------------

I'm going to suggest that you post this issue on any of the support forums for [Cordova](https://groups.google.com/forum/#!forum/phonegap)
/ [PhoneGap](http://forums.adobe.com/community/phonegap) or the [Slack group](http://slack.cordova.io/).

At the moment, I don't see any reason to suspect that this is an In App Browser issue. I do
question that {{redirect_uri}} value, but I'm not familiar enough with Yammer to help there.

For now, I'm going to close. If support from the other sites above seems to think that this
is a bug in the In App Browser, we can re-open.

> Redirection not happening with InAppBrowser when using with Yammer JS sdk for authentication
> --------------------------------------------------------------------------------------------
>
>                 Key: CB-12548
>                 URL: https://issues.apache.org/jira/browse/CB-12548
>             Project: Apache Cordova
>          Issue Type: Bug
>          Components: Plugin InAppBrowser
>    Affects Versions: 3.5.0
>         Environment: Ionic framwork
>            Reporter: praveen s
>            Priority: Critical
>              Labels: redirection
>             Fix For: Master
>
>   Original Estimate: 120h
>  Remaining Estimate: 120h
>
> I am trying Yammer client side OAuth Authentication. i am using the URL of format:
> https://www.yammer.com/dialog/oauth?client_id=xxxxxxxxxxx&redirect_uri=https://localhost/callback?type=mobile&response_type=token
> In InAppBrowser its showing Yammer login page, when i entered my email id, its trying
to take me to my organizations login page. here its failing, i mean its not redirecting from
yammer login page. its showing activity indicator and stuck there.
> when i open the same url in mobile browser its redirecting and working fine. so, the
issue is with InAppBrowser.
> Any idea on how to resolve it?
> ref: clinet-side flow in https://developer.yammer.com/v1.0/docs/oauth-2



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@cordova.apache.org
For additional commands, e-mail: issues-help@cordova.apache.org


Mime
View raw message