cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kerri Shotts (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (CB-12287) Issues with default simulator target
Date Wed, 01 Mar 2017 20:30:45 GMT

     [ https://issues.apache.org/jira/browse/CB-12287?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Kerri Shotts updated CB-12287:
------------------------------
    Fix Version/s:     (was: 4.4.0)
                   cordova-ios@4.4.0

> Issues with default simulator target
> ------------------------------------
>
>                 Key: CB-12287
>                 URL: https://issues.apache.org/jira/browse/CB-12287
>             Project: Apache Cordova
>          Issue Type: Bug
>          Components: iOS
>    Affects Versions: 4.3.1, 6.4.0
>            Reporter: Raymond Camden
>            Assignee: Kerri Shotts
>             Fix For: cordova-ios@4.4.0
>
>
> A few days ago I loaded up the XCode Devices menu and deleted a bunch of simulators.
I wanted to get rid of old ones and try to get both Cordova and Ionic defaulting to a modern
simulator. I didn't delete everything of course, but I did delete a bunch.
> Now I am unable to emulate. When I make a vanilla project, add ios (version is 4.3.1)
and do cordova emulate ios, i get:
> xcodebuild: error: Unable to find a destination matching the provided destination specifier:
> 		{ platform:iOS Simulator, OS:latest, name:iPhone 5s }
> 	The requested device could not be found because no available devices matched the request.
> 	Available destinations for the "HelloCordova" scheme:
> I can't even target another emulator. If I open the xcodeproj file though I can run it
just fine from XCode.
> I noticed that /cordova/lib/start-emulator has this:
> DEFAULT_TARGET="iPhone 5s"
> I don't know why. I tried changing it, just for the heck of it, and I *still* get the
same error.
> So... any ideas?



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@cordova.apache.org
For additional commands, e-mail: issues-help@cordova.apache.org


Mime
View raw message