cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mark (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CB-12459) network-information and device plugins cause deviceready to not fire on cordova-ios 4+
Date Wed, 15 Feb 2017 08:01:41 GMT

    [ https://issues.apache.org/jira/browse/CB-12459?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15867420#comment-15867420
] 

Mark commented on CB-12459:
---------------------------

Hello,
Thank you Kerri for the comment.
Yes I've tried both CLI's and every version of iOS platform from 4.0 onwards as well as plugin
versions. I've tried running the code on iPhone 4S (iOS 9.3.2), iPhone5 (10.2) and it has
an active registered sim in the phones registered on the mobile network.I have used Safari
to view the WebView degug and if I go to Console, there are Zero errors outputted. I've put
in console.log and alert statements throughout the test program and they all execute perfectly
except the one in the deviceready event.

( But please perhaps do not progress this isssue further until i have managed to convert the
project to CDVUIWebViewEngine. That might solve all issues. I have no idea how long this is
going to take because i've looked for examples online for a week now and have had no luck
at all - it might be very simple for a thoroughbred iOS developer but im a newbie. On a side
note, if this is such a major change in cordova to no longer support CDVViewController delegates
then i wonder why im having such problems finding even one example of how to make the conversion
to CDVUIWebViewEngine - I'd have thought that would have had a footnote comment on how to
do it atleast when the release came out ? )

jcesarmobile - i do understand your frustration at having to deal with so many apache "troublesome
users" who are a burden to you and you're probably under a lot of stress, but please understand
that i only reopened the issue because i was not sure you had seen (or would see) my comment,
and i was then sure you had misunderstood my issue. There was no maliciousness involved.I
simply did not realise that you held it as such a traversty of justice for me having reopened
the issue again. I am sorry - but please also understand that i have exhausted every possible
avenue and it's cost me 120+ hrs of lost development revenue trying to resolve this issue
and i and my client(s) are desperate. I realise the code doesn't compile - that is and was
my whole point. The change i made was what other users recommended. The offending line preventing
compilation could have just been removed as i did and it would have compiled fine but then
the app hangs because deviceready is never called nor the didFinishLaunchingWithOptions which
is actually more important than the webViewDidFinishLoad (which I've gotten around the Virtual
Machine problem which was the other issue why i wasnt able to call it outside not just slapping
any other call in place). 

Once again, thank you for your efforts in keeping these valuable tools available to us end
users. But please do not get so quickly offended or discourteous with it's userbase - who
are your customers. Please feel our "pain" as well, and hopefully we can meet halfway in resolving
issues especially one as "troublesome" as myself. The nature of some businesses needing to
make a living is that we have to bounce between 5 development languages, hundreds of thirdparty
tools, 16hr working days and we can therefore be a master of none even with 24 years of development
experience.

> network-information and device plugins cause deviceready to not fire on cordova-ios 4+
> --------------------------------------------------------------------------------------
>
>                 Key: CB-12459
>                 URL: https://issues.apache.org/jira/browse/CB-12459
>             Project: Apache Cordova
>          Issue Type: Bug
>          Components: Plugin Device, Plugin Network Information
>    Affects Versions: cordova-ios@4.3.1
>         Environment: Phonegap cli version 6.4.3, cordova cli 6.5.0, cordova platform
ios 4.3.1
>            Reporter: Mark
>            Assignee: jcesarmobile
>
> installing either of these 2 plugins results in an app deviceready event not firing.
It also results in the didFinishLaunchingWithOptions delegates not firing. 
> I used a bare skeleton of an app, but executing only these commands :
> phonegap create test com.test "Test"
> cd test
> cordova platform add ios
> cordova plugin add cordova-plugin-network-information
> I edit the MainViewController.h file and add the protocol to the declaration :
> MainViewController implements CDVViewController <UIWebViewDelegate>
> I edit MainViewController.m and simply add the method definition :
> - (void)webViewDidFinishLoad:(UIWebView *)webView {
>      
>     [super webViewDidFinishLoad:theWebView];  
> }
> I use XCode (7+) to install the app and run it on any iphone device and the deviceready
event never fires.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@cordova.apache.org
For additional commands, e-mail: issues-help@cordova.apache.org


Mime
View raw message